Problem sensitivite smart effector.



  • Good evening, I recently acquired a smart effector with arms and balls and it is being impossible for me to calibrate well, I adjust all the parameters in the config but I can not reduce the sensitivity in the tests, it does not respond to the commands I put on it or I do not know if I'm getting them right, and followed the wiki to the end, and the mesh of the bed makes me very tall and in red, could you help me?
    duet wifi 1.21rc2.
    thank you very much



  • I have exactly the same problem. I already have a Delta with a Smart Effector and that one works very good. I recently bought another Smart Effector for a bigger Delta and that shows exactly the same behaviour reported by Santiago. I can not probe reliably, since it triggers way to often and in between the probing points and then I get a G32 error saying that the probe triggered without touching the bed. I try again and again and sometimes eventually I can manage to finish probing, but in most cases not.
    I am using a Nimble with the latest adaptor plate.
    Of course I tried to lower the sensivity of the sensor without any luck.
    What can we do?



  • Good morning, in fact biggsis I have it mounted in a large delta and when I proceed to autocalibration the probe gives many points as good without being them and the mesh makes me fatal, last night I put back the old pieces of my effector and caliber without problems, try to lower the sensitivity but it was not possible, use the configuration provided by the rrf tol and I do not know if it is correct or not. But you can help us Thank you so much for everything.


  • administrators

    If the effector triggers (green LED flashes) while moving between probe points, that doesn't matter. The R0.4 recovery time parameter that we recommend you use in the M558 command (see the fitting instructions) will cause the probe to pause for 0.4 seconds after the travel move before it starts the probing move, to allow the probe electronics to settle.

    Things that can cause false triggering include:

    1. Excessive Z acceleration can cause the probe to trigger right at the start of the proving move.

    2. Some fans induce noise in the Smart Effector electronics if they are too close to it. In this case, the green LED may flash randomly even when the effector is stationary. So try probing with the fans all turned off, to see whether this is the problem.

    If the green LED flashes randomly even with no fans running, then your effector may be faulty and you should ask for it to be replaced.

    You can adjust the sensitivity as described on the wiki page. Higher numbers reduce the sensitivity. Always watch for the green LED to give the correct number of flashes after you send the command to change sensitivity, because occasionally the command is not recognised and you need to send it again.

    HTH David



  • good evening David, the effector when I raise the command to reduce the sensitivity does not flash the green light and turning off the power and put it back only flashes twice and I followed the command of the wiki, my effector flashes a little in the movements are for and marks in some places does not lower the mouthpiece of everything and marks it as good, when touching with the finger the nozzle marks it the sonsa for that reason I want to reduce the sensitivity. Many thanks for everything.


  • administrators

    If you can't change the sensitivity after trying several times, then I suggest you check the crimp connections at both ends of the wire connecting the Z probe connector MOD pin and the Smart Effector Control pin.



  • I haven't yet looked into it in detail, but mine has the very odd problem that it signals contact (green LED) when the heated bed is warm (over about 45 or 50C) and the head is closer than about 100mm to the bed. Turning off the bed heater makes it work as expected. The wires for the heated bed and the effector don't cross, although my Duet and all the wires are located directly under the heated bed, so it's conceivable there's some interference that might be hard to eliminate, short of relocating the Duet.

    I intend to try adjusting the sensitivity to work around this problem, but I haven't yet gotten around to that. For the moment, I can do my G32 probing cold and G29 after raising the bed temperature but after turning off the bed heater, to get a decent height map file.


  • administrators

    I've not heard of anyone having that problem before. What type of bed heater is it?



  • @dc42:

    I've not heard of anyone having that problem before. What type of bed heater is it?

    It's a Chinese knockoff of a SeeMeCNC Onyx (rev. 6) heater.


  • administrators

    Voltage?



  • Mine is 12v, with an aluminum plate above the heat bed. I've just done some more experiments. First, I tried adjusting sensitivity with the M672 command, as noted in the documentation. This didn't help; I got false alarms with sensitivities ranging from 1 to 255.

    Next, I next brought the hotend down to 5mm above the bed, with the bed cool, then turned on the bed heater (leaving the hotend heater off). The Z sensor triggered when the heat bed reached 57C (the target was 60C). I then took the temperature down in 5-degree increments. The Z sensor would turn off whenever I set a lower temperature (presumably because the heated bed was no longer receiving power), but would trigger again when the heat bed more-or-less reached the target temperature. This was true down to 40C, at which point I stopped lowering the temperature and began raising it in 5C increments. Again, the Z probe would trigger whenever the bed's temperature approached the target temperature. I wonder if it might have something to do with the way the Duet controls the approach to the target…? (I have done PID tuning on the bed heater.) Does it modulate the bed heater current in some way that might induce a magnetic field with some heating elements? If so, is there some way to adjust that -- say, by tweaking PID values?

    I then removed the aluminum plate, and that had no effect; the Z probe would trigger with or without it.

    I took the bed heater out of the frame, but left the heater plugged in. (It's got a fairly long cable.) The Z probe stopped triggering. I then moved the bed heater around and discovered that the Z probe would trigger whenever the bed heater got too close to the effector. What "too close" is varied with orientation; edge-on, I needed to get to within 3 or 4 cm of the effector. When I tilted the heater on its edge, so that a camera where the effector was would "see" it as a circular object, the effector would trigger when the bed was 10cm or more away -- about the same distance as triggers false alarms when everything's properly in place. Thus, I'm pretty sure it's the bed heater itself, not the way the cables are laid out.

    I also tried rotating the bed heater in the frame (mounted normally), to no good effect; false alarms would occur no matter the orientation.

    Based on this thread, I tried unplugging both my hotend fan and my print-cooling fan, reasoning that the combination of their magnetic fields and whatever the heated bed was producing might be causing problems, but unplugging the fans didn't help, so it seems to be the bed heater alone that's the culprit in my case.


  • administrators

    Evidently, when the bed heater is running at less than 100% PWM, current in the bed heater is causing sufficient magnetic field to induce current in the effector. I think this must be due to the particular heater element pattern used in that bed heater, because I've not heard of it happening before.

    I suggest you install firmware 1.21RC3 and then use the B1 parameter on the M558 command to turn heaters off during probing.



  • I looked for 1.21RC3 firmware and found this:

    https://github.com/dc42/RepRapFirmware/tree/dev/EdgeRelease/1.21RC3

    There's no DuetWiFiFirmware.bin file in that directory, though, which I believe is the file I'd need to update the firmware.

    FWIW, I did try going to bang-bang mode on the bed heater (by commenting out the "M307 H0…" lines in config.g and config-override.g). This greatly improves matters -- the Z probe doesn't produce any false alarm except for a brief blip, apparently when the heater turns off. (Just after the bed reaches its target temperature; I can also hear the power supply's fan drop in speed.)



  • @srs5694:

    I looked for 1.21RC3 firmware and found this:

    https://github.com/dc42/RepRapFirmware/tree/dev/EdgeRelease/1.21RC3

    There's no DuetWiFiFirmware.bin file in that directory, though, which I believe is the file I'd need to update the firmware.

    FWIW, I did try going to bang-bang mode on the bed heater (by commenting out the "M307 H0…" lines in config.g and config-override.g). This greatly improves matters -- the Z probe doesn't produce any false alarm except for a brief blip, apparently when the heater turns off. (Just after the bed reaches its target temperature; I can also hear the power supply's fan drop in speed.)

    See upgrade notes here - https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md



  • OK, I've now tried the 1.21RC3 firmware and "M558… B1". This works, but it has a big drawback: I get heating faults during probing. Specifically, when I tried probing after both the bed and the hot end had reached their target temperatures (60C and 210C, respectively), the hot end produced a heater fault with the message "temperature excursion exceeded 15.0C." (I could see the hot end temperature plunging throughout the probing process. The bed temperature dropped, too, but not as dramatically.) I also tried probing while both the bed and hot end were still being heated. In this case, both of them produced heating faults, with the message "temperature rising much more slowly than the expected 0.1C/sec" (or 0.0C/sec for the hot end).


  • administrators

    For now you could try reducing the travel speed between probing (T parameter in M558) and if it is safe to do so, also reduce the dive height (H) and increase the probing speed (F). This will allow the heaters to stay on for more of the time during probing. Meanwhile I will look at suppressing heater fault detection when the heaters are suspended.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.