Duet Wifi & mini-height sensor board problems.



  • I've just replaced the standard Ormerod 2 Z probe with DC42 mini-height sensor board. (Printer was working with the old Z-probe ok)

    I believe I've followed the instructions correctly on https://miscsolutions.wordpress.com/mini-height-sensor-board/ and using https://duet3d.dozuki.com/Wiki/Duet_Wiring_Diagrams as reference.

    • Wiring photo (in case I've mis-wired) - note that I used my an old Ormerod 2 4-pin Z-probe wire and pin 4 does not connect to the Z-probe. I then cut and wired the Duet side)

    • Config.g has M558 P1 (full config.g at the end) , but LED's on the mini-differential board do not flash on boot

    • Readings seem to be either 466,566 or 0 mostly (occasionally I've seen 56 or 66) which seems odd. No LED flashes during this process Demo here

    • Wires buzz out OK. (wiring tests here)

    I notice I'm on firmware version 1.19 while I report this. Do I need to update to firmware version 1.20?

    Any thoughts welcome. Thank you.


    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.19.2 (2017-09-01)
    WiFi Server Version: 1.19.2
    Web Interface Version: 1.20

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Dec 20 2017 22:03:57 GMT+0000 (GMT Standard Time)
    
    ; General preferences
    M111 S0                            ; Debugging off
    G21                                ; Work in millimetres
    G90                                ; Send absolute coordinates...
    M83                                ; ...but relative extruder moves
    M555 P2                            ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1                   ; Set axis minima
    M208 X225 Y215 Z180 S0             ; Set axis maxima
    
    ; Endstops
    M574 X0 Z0 S2                      ; Set active low endstops
    M574 Y1 S1                         ; Set active high endstops
    M558 P1 X1 Y0 Z1 H5 F120 T6000     ; Set Z probe type to unmodulated, the axes for which it is used and the dive height + speeds
    G31 P500 X0 Y0 Z1.4                ; Set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20           ; Define mesh grid
    
    ; Drives
    M569 P0 S0                         ; Drive 0 goes backwards
    M569 P1 S1                         ; Drive 1 goes forwards
    M569 P2 S1                         ; Drive 2 goes forwards
    M569 P3 S1                         ; Drive 3 goes forwards
    M569 P4 S1                         ; Drive 4 goes backwards
    M350 X16 Y16 Z16 E16:16 I0         ; Configure microstepping without interpolation
    M92 X87.489 Y87.489 Z4000 E427.394:427.394 ; Set steps per mm
    M566 X300 Y900 Z12 E120:120        ; Set maximum instantaneous speed changes (mm/min)
    ;M203 X2000 Y6000 Z180 E1200:1200   ; Set maximum speeds (mm/min) (default)
    M203 X2000 Y6000 Z180 E1200:1200   ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250:250        ; Set accelerations (mm/s^2)
    M906 X800 Y1000 Z800 E1000:1000 I30  ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                            ; Set idle timeout
    ; Heaters
    M305 P0 T10000 B3988 C0 R4700      ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                       ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700     ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260                       ; Set temperature limit for heater 1 to 260C
    M305 P2 T100000 B4138 C0 R4700     ; Set thermistor + ADC parameters for heater 2
    M143 H2 S260                       ; Set temperature limit for heater 2 to 260C
    
    M307 H0 A97.1 C574.2 D0.9 S1.00 V10.9 B0
    ;M307 H1 A675.6 C92.0 D5.5 S1.00 B0  ;values defined in config.g.override
    ;M307 H2 A349.0 C85.2 D10.4 S1.00 B0  ;values defined in config.g.override
    ; Tools
    M563 P0 D0 H1                      ; Define tool 0
    G10 P0 X0 Y0 Z0                    ; Set tool 0 axis offsets
    G10 P0 R0 S0                       ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2                      ; Define tool 1
    G10 P1 X10 Y0 Z0                   ; Set tool 1 axis offsets
    G10 P1 R0 S0                       ; Set initial tool 1 active and standby temperatures to 0C
    
    ; Network
    M550 POrmerod 2 DuetWifi           ; Set machine name
    M552 S1                            ; Enable network
    ;*** Access point is configured manually via M587 by the user
    M586 P0 S1                         ; Enable HTTP
    M586 P1 S1                         ; Enable FTP
    M586 P2 S0                         ; Disable Telnet
    
    ; Fans
    M106 P0 S0 I0 F500 H-1             ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 H-1        ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 H-1        ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Custom settings are not configured
    
    

  • administrators

    If the LED doesn't flash on boot up, but you get a reading close to 0 when the sensor is a long way from the bed followed by about 465 and then 535 when it is close, but still no LED, then it sounds like the LED has failed or isn't properly soldered on. Please ask your supplier for a replacement sensor.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.