First extrude of T1 fails. Mix Nozzle



  • Hello @all,

    after i get up my CoreXY running (use T0) and solve the Issues with the BlTouch, i want to do the "Next Step".
    I build in a "Mix-Hotend": 1 Nozzle with 1 Heater but 2 Extruder.
    I bought it here in China, and its from "NF"….
    The difference to the Chimera is, that you need to retract the "active" Material at least 41mm.

    I´m also a bit new to the Duet, but already read that there is the possibility to use 3 Macros for Tool-Change.
    But i´m a bit lost about it.

    My actual Problem:
    I use S3D as Slicer and its Function for Dual-Extruding Assistant.
    I adjust the Retract for Tool-Change to 45mm, and whe it comes back to -0,1mm (Speed 1800mm/min)

    During Printing, it works well, but the FIRST Tool-Change has the Issue, that the Material from Tool0 retracts 45mm, but from Tool1 the Material NOT extrude the 45 mm firstly, before start to Print.
    Means: the first Layer from Tool 1 is totally worse, because NO Material in the beginning.....

    I also use the additional "Prime Pillar, 22mm widht" but a lack of 45mm Raw Material is way too much.

    Anyone an Idea what i could/should adjust ?

    And back to the Duet, i also need some advice, please.
    In which Order are the 3 Macros called from the Duet ? (okay....tpost*.g will be the last....)
    Tfree or Tpre first ?

    Related to the WiKi, i also tried to Start with a heat-up.
    But when i fill in these Command in Tpre0 and Tpre1, i directly get an Alarm:
    Error: Push(): stack overflow!
    Error: Push(): stack overflow!
    Error: Max open file count exceeded.

    Thanks in advance for any Help and/or Suggestions !!


  • administrators

    Either do the retraction/un-retraction in S3D, or do it in the tool change files. Not both.

    If you want to do it in the tool change files, retract filament in tfree and un-retract it in tpost. The tpre file is rarely used for anything. Start those files with M83 so that the extruder motion will be relative.

    If you got a stack overflow message, that probably means that you created a recursive macro, for example by putting a T command or a M109 command in the tool change macro.



  • Thanks for the Help !

    Of course i only use the Duet-Macros OR the Function in S3D. I only start with S3D, because i was not clear which Macro will start and which Commands to put in there….
    I will try now.

    For the Stack Overflow:
    Yep. You are right !!!! I had a Missunderstood from the WiKi-Page https://duet3d.dozuki.com/Wiki/Multiple_tools_and_Tool_change_macros and fill in these Commands in the Tfree.g to Start:

    Tool Preheat
    When starting up you can arrange for both tools to start heating as shown in the following example
    G10 P0 S200 R150 ; Set tool 0 active and standby temperatures
    G10 P1 S200 R150 ; Set tool 1 active and standby temperatures
    T1 P0 ; Select tool 1 to turn it on but don't execute tool change scripts
    T0 ; Select tool 0
    M116 ; Wait for all temperatures to be reached
    This will turn both heaters on, heating tool 0 heater to 200C and tool 1 heater to 150C.

    And there is this T0 Command in there, that starts the Macros again…..



  • @dc42
    I tried that and retracts and un retracts fine for T0. But can't do it for T1. I created a file called tfree1.g but I guess there is no command to call that file.


  • administrators

    File tfree1.g will be called when tool 1 is freed, tpre1.g will be called just before tool 1 is activated, and tpost1.g will be called just after tool 1 has been activated. Similarly for any other tool numbers you create.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.