Limit Z movement before homing?



  • Hi,

    I have a coreXY machine and the bed moves. This results in the movements being unintuitive. EG, when you move Z down, it actually moves the bed up. However, when i want to move the bed down to change a nozzle or whatever, I end up pressing the "down" button resulting in the bed moving up. If the printer is not homed, that results in the bed crashing into the head of the printer, me looking dazed and confused for a few minutes, before frantically realizing what is going on, spending a few seconds on how to make the noise stop, then mashing the emergency stop button.

    Its very stressful.

    Is there a way to disable z movement before homing?

    Thanks!


  • administrators

    The latest 1.21RC3 firmware does that.



  • Do you recommend the average user install the release candidates or wait for the full updates?


  • administrators

    Yes if the RC includes a new feature or bug fix that you want.



  • There was another thread about this, with corexy (with a bed moving in Z rather than an XY gantry moving in Z) you have to use phrases like increase Z or decrease Z rather than up or down, as it obviously moves down for +Z. There was talk of changing the babystepping icons on paneldue/DWC to show two lines with arrows opening them up, or closing them down which would be more intuitive irrespective of which kinematic scheme your printer uses.

    I think it becomes even more common to mess it up if one printer is a corexy (with moving Z bed) and the rest are cartesian or delta.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.