Smart Effector tilts when Auto Leveling



  • Hi,
    I did some searching but haven't found an answer to my problem or is it a problem.
    I initiate auto level, all three axis home then move to the bed, when the tip of the nozzle touches the bed it seems that the effector tilts until the green LED flashes then moves to the next point and it repeats the same action. I haven't tried to print yet because I am not sure if this is normal or not. I didn't change any of the defualt code for auto leveling.
    If someone could point me in the right direction would be awesome. I am so close to doing my first print.


  • administrators

    Did you follow the instructions on the wiki, in particular test that the green LED flashes when you give the nozzle a sharp tap upwards? Did you use the M558 settings recommended on the wiki?



  • A video of it doing this would be useful also a copy of your Config.g and Bed.g files may help

    Post the config and bed files first tho there may be something obvious in there while you are getting a vid of it.



  • I did but I didn't change the M558 feed rate from the F120 to F1000 and the M558 H from H5 to H30.
    Made those changes and now it seems fine.
    Thanks.


  • administrators

    I'm glad you got it working. The F1000 parameter is the critical one because the Smart Effector is designed to be insensitive to slow changes in the output from the strain gauge, otherwise it would respond to temperature changes. The H30 is for initial calibration; you can return it to H5 once you have put approximately the right values in your M665 command in config.g.



  • Awesome, thanks for the help again.
    It is great to have help learning all this.
    Really having a lot of fun and it is so cool to have something you make work.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.