Layer problems Tronxy X5S



  • I am able to print a BEAUTIFUL first layer but when it begins to start the 2nd layer its almost like the z axis moves to far and throws everything. I think speed maybe one of my issues. Any suggestions would be great. Here is my config.

    [c]; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z4000 E420 ; Set steps per mm
    M566 X9000 Y9000 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10000 Y10000 Z12 E3600 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z50 E1000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-50 Y-20 Z0 S1 ; Set axis minima
    M208 X290 Y300 Z76 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops
    M558 P0 X0 Y0 Z1 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:315 Y15:315 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S150 ; Set temperature limit for heater 0 to 150C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S320 ; Set temperature limit for heater 1 to 320C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P1 D0 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C [/c]


  • administrators

    Are you sure that your Z steps/mm value (4000) in the M92 command is correct?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.