Trouble with adding an extra heat bed



  • I have added an extra heat bed (i.e. I have two heat beds) for the large print bed I have. One of them is connected with the heat bed power supply and the other one is actually a larger heater which requires an external power supply (and also a SSR). The heat bed is plugged into E1 Heater.

    The issue I am experiencing right now is that when I tried to switch the bed to active, the temperature increases uncontrollably and the only way I can stop it is by shutting down the whole machine by unplugging.

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Mar 07 2018 17:28:25 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PXXXX ; Set machine name
    M551 PXXXX ; Set password
    M552 S1 ; Enable network
    M587 S"Jump24" P"Jump24" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X256 Y256 Z16 E256 I0 ; Configure microstepping without interpolation
    M92 X1280 Y1280 Z600 E6660 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z180 E3000 ; Set maximum speeds (mm/min)
    M201 X800 Y800 Z50 E5000 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1500 E650 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X800 Y350 Z700 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:785 Y15:335 S20 ; Define mesh grid

    ; Heaters
    M141 H2 ; Assign chamber heater to heater 2
    M301 H2 P-1 ; Set heater 2 to bang-bang mode
    M305 P0 T100000 B4072 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S100 ; Set temperature limit for heater 2 to 100C

    ; Fans
    M106 P0 S1 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 T45 H1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P1 D0 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


  • administrators

    You can't use M301 to force bang-bang mode any more. Use M307 to do that instead.

    Instead of configuring your bed heaters as 1 bed + 1 chamber heater, in RRF 1.20 and later you can configure them as 2 bed heaters:

    M140 H0:2



  • Thanks dc42, so does that mean I should replace the line:

    "M141 H2" with "M140 H0:2"


  • administrators

    Yes, that should do it. Then you need to use the P parameter in M140/M190 commands to specify which bed heater you are referring to, 0 (default) or 1.



  • Do you mind walking me through how to use the P parameter to specify the heaters?

    After I made the change to the M140 and also M307, the only difference I saw was that the 3rd tool has been removed from the browser and I am only left with the Extruder and heat bed.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.