Low speed problem homing



  • Good afternoon, yesterday I changed the engines nema 17 of my kossel delta of 1.8 degrees to 0.9 degrees and pulleys of 16t and now the homing makes me very slow and I do not know what I have to touch anymore and I adjust the speed in homedelta.g, Do you have some more touching site? thank you very much for everything.
    PS: I attach a copy of homedelta
    ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jan 12 2018 23:47:22 GMT + 0100 (Standard Time Romance)
    G91; relative positioning
    G1 S1 X805 Y805 Z805 F27000; move all towers to the high end stopping at the endstops (first pass)
    G1 X-5 Y-5 Z-5 F27000 S2; go down a few mm
    G1 S1 X10 Y10 Z10 F27000; move all towers up once more (second pass)
    G1 Z-5 F27000; move down to a few mm so that the nozzle can be centered
    G90; absolute positioning
    G1 X0 Y0 F27000; move X + Y to the center



  • I think you should increase the F parameter which is the speed



  • @paboman:

    I think you should increase the F parameter which is the speed

    thanks for your answer, but more than 27000?



  • did you change m92 steps per mm to match the new stepper motors and pulley in config.g?



  • @robm:

    did you change m92 steps per mm to match the new stepper motors and pulley in config.g?

    yes, all the changes made in the config.g



  • When I go to 256 microstepping(yes all the steps per mm are correct), the homing is very slow as opposed to 16.


  • administrators

    The maximum speed of homing moves is much slower than for printing moves, because the endstops have to be checked. So if you use high microstepping, you need to use slower homing speeds. The 1.21RC firmware should allow slightly faster homing than previous versions did.

    To check whether you are trying to home too fast for the microstep setting, first make sure the printer has a long way to go to home, then run M122, then home it. Then run M122 again and check the MaxReps field. If it is higher than about 50 then you are homing too fast.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.