PanelDUE 7i USB query

  • Is there something I need to do to get the PanelDUE 7i to respond on USB? Should it respond when firmware 1.17 is already loaded?

    I received PanelDue 7i yesterday, works nicely, connects to DuetWifi, all seems happy. Has firmware 1.17 so want to update.

    Have Macs and Linux here (Windows 10 only if I go and dig out that old laptop drive). Initially I followed the instructions to load run bossac, but in the current state (1.17 loaded) the device does not appear on my USB list.

    Have tried: 2 mac laptops (High Sierra), old iMac (El Capitan), Linux laptop. Think the Macs all put out 2A on USB? Tried with power coming from DuetWifi (green and blue wires pulled from Molex connector and taped off), multiple USB cables. In configuration with power supplied by DuetWifi, can swap cable to the Duet and the Duet appears on the laptop USB device list (so cable seems good). In all cases powering through just the USB is sufficient to light up the display and get it working to go into setup and click other buttons.

    Do I have to erase first to get it to appear? I'm reticent to do that :-))

  • As I wanted to update the Panel, it didn't appear right away. I had to press the Erase-Button first, then it popped on as a COM-Device.


  • administrators

    The USB port on PanelDue is used only for uploading firmware to it, and for providing power in those few setups that need it. It is not active in normal running mode.

Log in to reply