WebControl Rel 1.21 problem



  • Hi David -
    Dumped my Radds and am installing Duet Ethernet system. So far so good but then hit a wall.
    Preliminary Rel 1.21 clean install appears working properly communicating with the terminal and getting reasonable responses. but invoking of the WebControl ( Chrome Win7x64 ) the screen is text based/non-graphical. I suspected the problem to be in the \sys\ Duet2Comb… and/or the DuetEther... binary files. I tried with both present, and with each individually in the folder. No joy.
    Not sure about the M997 behavior. If the Duet2C... is missing it tells me so. If it is present or both are present M997 evokes no response ( no ok or anything ). Humm!
    But props to you folk for a really clean piece of hardware and some, so far, excellent firmware. Love the TMC 2660 functionality.
    Cheers bob


  • administrators

    Thanks for buying a Duet!

    It sounds like the CSS files are missing. I suggest you move the SD card to a PC, rename the /www folder to /www-old, create a new /www folder, and extract DuetWebControl.zip into it preserving the directory structure. You should end up with subfolders js, css and fonts within /www, each with files in it.

    While you are at it, run a disk checker on the SD card in case there are cross-linked clusters or similar.



  • Magic. Fresh download from the website and extracted to new www folder. The old>new www directories appear identical. Must have been some sort of file corruption first time around although the SD checker saw no faults. Half a league onward to the smoke tests rode the 600.

    Thanks for the help …....... Cheers bob



  • David -

    Curses !

    #1 problem
    For unknown reason stopped working. Now, when trying to access DWC I get
    " Your Duet rejected the HTTP request . . . ." using the M552 S1 assigned IP of 10.0.0.204.
    The Network comm light is flashing. No smoke.

    #2 problem
    Panel Due does not illuminate either under USB power or under 24vdc board powerup. Never did.

    Sorry to be a pest. bob


  • administrators

    #1 try a different SD card

    #2 disconnect it from the Duet and connect the USB port of the PanelDue to a PC. Does a Bossa port appear? If so then the firmware has been erased and it needs to be re-flashed.



  • David -

    Still no joy. Purchased a new, Sandisk class 10 32gb SD card. New download of 1.21 and performed a fresh install. I think I did everything right and got the square bits in the square holes..
    Same connection message using the fresh M552 ip address response 10.0.0.204 - actually the complete message is >>>

    Your Duet rejected the HTTP request: page not found
    It obviously sees the Duet and is looking for a "page" ( I'm clueless what the page means )

    I wish I had screenshots or similar so I could confirm in full detail the required SD card file structure. What I don't understand is that it worked once ( and only once ). I did not connect any devices to Duet other than USB and Ether cable and PanelDue although I did once briefly power up the 24v input. Pretty sure I didn't cook anything.



  • @balrags:

    Same connection message using the fresh M552 ip address response 10.0.0.204 - actually the complete message is >>>

    Your Duet rejected the HTTP request: page not found
    It obviously sees the Duet and is looking for a "page" ( I'm clueless what the page means )

    Do you have any type of ad blocking software running on that browser? Malware protection?

    Can you try a different browser, or different computer, tablet/phone browser to see if the error is the same?

    I think I read you have successfully connected via USB. If so, can you post the output of the M122 command?

    John


  • administrators

    1. Please confirm that you are not using an SD card extender cable.

    2. Check what address appears in the address bar of the browser, in case it it auto completing and adding some characters after the IP address.

    3. Run M39 from USB to check that the SD card is mounted.

    4. Run M503 from USB and check that it reads and echoes the config.g file successfully.



  • 1 /2 /3 Check
    4 - Oops. The SD card does have a config.g in the sys directory but M503 returns not found. Corrupt perhaps ?

    Doctor appointment - will run the configuration tool afresh when I return



  • Still no luck. So I entered List SD files M20 >none. Tried to initialize the SD with M21 > Cannot initialize / Card is unusable.

    Ran the above on both the original SD and the replacement. Same results. Both cards are fine in the PC ( all files list out ) and Windows CheckDisk verifies all is copacetic.

    Have I got a defective card reader in the Duet ( no extender ) ? Are other other tests I can perform. I'm a slightly software/electronics naive mechanical engineer so I feel a bit at sea.


  • administrators

    After running M21 to try to mount the card, run M122 and in the Platform section of the report see if the SD card was detected.



  • M121 response "…....SD card 0 detected........."


  • administrators

    I suspect an issue with the SD card socket. Please ask your supplier to replace the Duet.



  • Thanks, so right. Replacement board configuring nicely.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.