Extruder issue?



  • Please forgive me if I have posted in the wrong thread. I have upgraded my printer with the Duet WiFi and have had an issue that has had my printer out of commission for a few months. I have gone over the wiki and tried to fix the issue to no avail. My problem is when the printer first starts and has warmed up everything is as it should be, with the exception of one major issue. The extruder runs great for a few seconds then skips, then skips some more, then goes haywire rotating back and forth without advancing. Things I have tried… I have tried increasing the voltage, I tried changing the steps per mm/min, I have tried 4 different steppers (note: all the steppers work perfect in my other printer) I have even changed to the other driver port just to encounter the same issue.I have also tried with three different versions of software and still the same.

    I am at my wits end and have no idea what the issue is or where it lies. I am assuming it is gcode related within the config but cannot seem to figure it out with creating it from scratch with the config tool or using another config I download from someone else that has a working printer. I am truly baffled and am in need of some help. I have built this printer from scratch and have invested a conciderable amount of money into it and would be so pleased if I could finally get it up and running. I have included my config file if anyone could have a look and see if there is anything I need to fix or if you could steer me in the right direction I would be so very grateful.

    I have also included a link to a video to show what is happening. Here…. (https://youtu.be/dlJIXUH9u5E)

    The printer specs are as follows CoreXY, piezo z probe 300x300x400, all endstops at the min position and, a 12v power supply

    Config…....
    ; CoreXY sample config file for dc42 Duet firmware

    M111 S0 ; Debug off
    ; Network
    M550 P******** ; Machine name (can be anything you like)
    M551 P******** ; Machine password (used for FTP connections)
    M552 S1 ; Enable network
    M587 S"" P"***" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    ; Machine configuration
    M569 P0 S0 ; X Motor - Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S0 ; Y Motor - Drive 1 goes forwards
    M569 P2 S1 ; Z Motor - Drive 2 goes forwards
    M569 P3 S1 ; Ext 1 - Drive 3 goes forwards
    M569 P4 S1 ; Ext 1 - Drive 4 goes forwards
    ; If you use an endstop switch for Z homing, change Z0 to Z1 in the following line, and see also M558 command later in this file
    ; M574 X1 Y1 Z0 S1 ; set endstop configuration (X and Y and endstops only, at low end, active high)
    M574 X1 S0 ; Endstop configuration: X is min, NO, active LOW
    M574 Y1 S0 ; Endstop configuration: Y are min, NO, active LOW
    M574 Z1 S0 ; Endstop configuration: Y are min, NO, active LOW
    M667 S1 ; set CoreXY mode
    M92 X159.39 Y159.39 Z800 ; Set axis steps/mm
    M92 E102.0500 ; Set extruder steps/mm
    M906 X1000 Y1000 Z1000 E1000 I60 ; Set motor currents (mA)
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E20000 ; Maximum speeds (mm/min)
    M566 X1200 Y1200 Z1200 E1200 ; Maximum jerk speeds mm/minute
    M208 X200 Y200 Z200 ; set axis maxima (adjust to suit your machine)
    M208 X30 Y20 Z-2.77 S1 ; set axis minima (adjust to make X=0 and Y=0 the edges of the bed)
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    Z-probe

    See http://smoothieware.org/zprobe

    zprobe.enable true # Set to true to enable a zprobe
    zprobe.probe_pin 1.28^! # Pin probe is attached to, if NC remove the !
    zprobe.slow_feedrate 5 # Mm/sec probe feed rate
    #zprobe.debounce_count 100 # Set if noisy
    zprobe.fast_feedrate 100 # Move feedrate mm/sec
    zprobe.probe_height 5 # How much above bed to start probe
    gamma_max_endstop nc # Normally 1.29. Change to nc to prevent conflict,

    leveling-strategy.delta-grid.enable true # The strategy must be enabled in the config, as well as the zprobe module.
    leveling-strategy.delta-grid.radius 290 # Radius of the bed, must be specified. This needs to be at least as big as

    the maximum printing radius as moves outside of this will not

    be compensated for correctly

    leveling-strategy.delta-grid.bed_x 280 # Reduced by 0mm for home offset

    leveling-strategy.delta-grid.bed_y 280 # Reduced 0mm for home offset
    leveling-strategy.delta-grid.bed_z 500 # Unused, manual probe only
    leveling-strategy.delta-grid.cal_offset_x 0 # Add offset + probe head width
    leveling-strategy.delta-grid.cal_offset_y 0 # To clear clips
    leveling-strategy.delta-grid.size 7 # The size of the grid, for example, 7 causes a 7x7 grid with 49 points.

    ; Thermistors and heaters
    ;*** If you have a Duet board with 1K thermistor series resistors, change R4700 to R1000 to the following M305 commands
    ; You can also use S and B parameters to define the parameters of the thermistors you are using
    M305 P0 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    M305 P2 R4700 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M301 H1 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 0
    M301 H2 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 1
    M570 S120 ; Increase to allow extra heating time if needed

    ; Tool definition
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a dual-nozzle build, un-comment the following 3 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures

    ; FANS
    M106 P0 F200 ; Set PWM frequency to reduce high pitch whine.
    M106 P0 T60 H1 ; Enable the auto hotend cooling fan to kick on at 60c.

    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here
    T0 ; select first hot end



  • That kind of sounds like a broken wire or loose crimp connection in the extruder stepper bundle. Use a multimeter to do a continuity check on each wire pin to pin.

    If that all checks out you could plug it into a different stepper driver and configure it for the extruder motor for testing and see if it behaves the same.

    The config looks ok I think. The jerk and accell look a little high on the extruder. Try halving them.

    Is the file you're trying to print sliced with relative extruder movements enabled?



  • Do you know what the model number of the motor is, I wonder if a really high inductance could cause this kind of issue.
    I have also seen stepper motors behave strangely if you have the stepper motor free like that and with no load on the shaft at some speeds/current settings. Have you tried to install it on the printer yet, even holding the motor firmly to the table might cause it to change.

    It sounds like you may have tested it but like Phaedrux said make sure to check for a bad connection and you can try moving the wires around a little to see if you can make it run normally if the wires are put in to a specific bend.



  • I have done all that you have stated, I originally had it on the machine and recently did this setup to be able to tinker with it while spending time with my family instead of being in my man cave for hours on end where my printer is. I have checked all the connections they are all soldered with new wires and all the motors work perfect on my other printers with no issues. I first noticed this while trying a test print and have had no luck since. I have also tried it on the other extuder driver as well with no luck. This not only happens while printing but when I manually move the extruded with the online and pandue controls as well so slicing configuration is not a cause. I will try to lower the jerk and accell and report back.

    Note: I get the same response with my I3 stock steppers only when connected as extruders
    Stepper specs: Busheng 17HD60001-22B
    1. Step angle: 1.8°
    2. Holding torque: 800mN.m
    3. Rated current/phase: 1.7A
    4. Phase resistance;: 1.8 ohms

    Here is a link to the steppers I am using (https://www.aliexpress.com/item/3d-printer-parts-High-Holding-Torque-stepping-motor-Nema17-17HD60001-22B-1-7A-102g-cm2-Length/32808682385.html)



  • I solved my issue! Thank you guys for the help



  • @Kevin3737:

    I solved my issue! Thank you guys for the help

    That's great, but don't leave us hanging! What was it?!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.