Z axis motors not getting power



  • Hi,
    I have my motors hooke up to the my duex and they are set under z axis with the M584 command but they still arent getting power because under the machine properties tab it says their motor current is 0. how would i change that to 800?
    Here is my config
    Thanks
    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Mar 29 2018 21:22:13 GMT-0400 (Eastern Daylight Time)
    ; Custom settings
    M584 X0 Y1:4 Z5:6:7:8:2 E3:9

    ; General preferences
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PUnderground Printing- Jumbo ; Set machine name
    M552 S1 ; Enable network
    M587 S"KQVQM" P"SVLFBZMC3PK8893X" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes back
    M350 X32 Y32 Z32 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z4000 E420 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 U0 Z0 S1 ; Set axis minima
    M208 X838.2 Y762 Z1117.6 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S0 ; Set active low endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:823.2 Y15:747 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C


  • administrators

    The Machine Properties tab doesn't take account of axis mappings, so it isn't giving you the true picture.



  • do you know any reason it wouldn't be moving either up or down


  • administrators

    Is the DueX5 definitely getting VIN power?

    Does the Settings General page of DWC mention the DueX5?

    Does M122 list the status of 10 drives, or only 5?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.