Unknown problem with board



  • I have been using my duet wifi for a few months now and it has worked well. I recently tried to setup the duex5 with my printer, but during the process, I made some mistake. I am not sure where I went wrong, but now my board isn't functioning properly. I may have pressed the erase button during the process, I am not sure. It is possible i have messed up in some other way. I have tried to reflash the board with Sa-mba, but I can't even get the Bossa port to show up in device manager. I also had checked for the other comm port to connect through pronterface, and that wouldn't appear either. I tried a different usb cable.

    I apologize for the vagary of this post, but I'm honestly not sure where I went wrong.

    Thanks,
    Ian



  • When you plug in the duet, what sort of leds light up?

    Have you unplugged everything from the main duet board?



  • ok when I plug in only the USB, i get a 5v light and the light between the reset button and the USB socket. Is there some jumper or something that I need to move to get it to work? And yes I unplugged the connections to the main board.



  • It looks like the 3.3v regulator that supplies power to the chip isn’t working. That’s usually because there is a short between the 3.3v rail and ground. Do you have a multimeter to test? And an external 3.3v supply?

    And just so we are clear you have absolutely nothing connected to the duet board (eg all the endstops unplugged, etc)



  • ok so everything is now unplugged, completely, Now the 3.3v led is green and it is communicating with pronterface. Thank you very much. My guess is that I had an endstop plugged in improperly and it was shorting out the 3v rail. Does that seem about right?



  • Yep, happened to me.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.