Z offset Not Doing Anything



  • Hi all

    I'd appreciate some help with an issue I am having with my duet3d setup.

    Rostock V3 Max with duet wifi FSR Probing.

    I found the measured Z offset needed for my setup (confirmed by the baby stepping amount and also measured when sending Z=0 initially. My Z offset calls for -0.180mm . I set it at the config.g file and found that it does not do anything. Even after I set that value to the Z offset needed, I find I have to baby step by the same amount every print. Can someone see if I am missing something here?

    Config.g File:

    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimeters
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
    M665 R144.158 L291.06 B140 H385 X0 Y0 Z0; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them
    M350 X16 Y16 E16 I1 ; Set 16x microstepping with interpolation
    M92 X160 Y160 Z160 ; Set axis steps/mm
    M906 X1700 Y1700 Z1700 E1200 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
    M566 X1200 Y1200 Z1200 E1200 ; Maximum instant speed changes mm/minute

    ; Thermistors
    M305 P0 T100000 B3950 R4700 H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 X200 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    ;M305 P2 T100000 B3974 R4700 H30 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds

    ; Fans
    M106 P1 T45 H1 ; Enable thermostatic mode for fan 1

    ; Tool definitions
    M143 S320 ; Define tool max temp 320c
    M143 H0 S140 ; Define HB max temp 140c
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a single-nozzle build, comment the next 2 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures
    M92 E468.77:468.77 ; Set extruder steps per mm

    ; Z probe and compensation definition
    M558 P4 X0 Y0 Z0

    ; grid compensation
    M557 R110 S15

    G31 X0 Y0 Z-0.380 P500 ; Set the zprobe offset and threshold (determine your printer's Z offset value). For a delta, use zero X and Y offset.

    ;*** If you are using axis compensation, put the figures in the following command
    ;M556 S78 X0 Y0 Z0 ; Axis compensation here

    T0 ; select first hot end

    And bed compensation:

    ; Auto calibration routine for SeeMeCNC Rostock MAX V3
    ;
    ; About the G30 S parameter
    ; Used to specify what calibration computation to perform.
    ;
    ; S=-1 Don't adjust anything, just print the height error at each probe point
    ; S=0 Equivalent to S= <number_of_points_probed>; S=3 Adjust homing switch corrections only
    ; S=4 Adjust homing switch corrections and delta radius
    ; S=6 Adjust homing switch corrections, delta radius, and X and Y tower position offsets
    ; S=7 Adjust homing switch corrections, delta radius, X and Y tower position offsets, and diagonal rod length

    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G28 ; home the printer

    G1 X0.00 Y130.00 Z10 F15000 ; move to just above the first probe point (from the list below)

    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 13 points, 6 factors, probing radius: 130, probe offset (0, 0)
    G30 P0 X0.00 Y130.00 Z-99999 H0
    G30 P1 X112.58 Y65.00 Z-99999 H0
    G30 P2 X112.58 Y-65.00 Z-99999 H0
    G30 P3 X0.00 Y-130.00 Z-99999 H0
    G30 P4 X-112.58 Y-65.00 Z-99999 H0
    G30 P5 X-112.58 Y65.00 Z-99999 H0
    G30 P6 X0.00 Y65.00 Z-99999 H0
    G30 P7 X56.29 Y32.50 Z-99999 H0
    G30 P8 X56.29 Y-32.50 Z-99999 H0
    G30 P9 X0.00 Y-65.00 Z-99999 H0
    G30 P10 X-56.29 Y-32.50 Z-99999 H0
    G30 P11 X-56.29 Y32.50 Z-99999 H0
    G30 P12 X0 Y0 Z-99999 S6

    G1 X0 Y0 Z150 F15000 ; get the head out of the way of the bed

    Also, config-override file:

    ; This is a system-generated file - do not edit
    ; Delta parameters
    M665 L291.060 R144.158 H385.000 B140.0 X0.000 Y0.000 Z0.000
    M666 X0.000 Y0.000 Z0.000 A0.00 B0.00
    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B1
    M307 H1 A526.0 C247.6 D3.2 S1.00 V12.2 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0</number_of_points_probed>


  • administrators

    Your slicer start script probably includes G28 but doesn't probe the bed before printing, so the G31 offset is never used. After G28, either run G32 to run auto calibration, or position the head a few mm above the centre of the bed and send G30 to do a single probe.



  • Actually, my slicer does not include that. I just looked at the script for starting a print...


  • administrators

    Can you show the first 50 or so lines from the GCode file you are trying to print?



  • This post is deleted!


  • This post is deleted!


  • @dc42 said in Z offset Not Doing Anything:

    Can you show the first 50 or so lines from the GCode file you are trying to print?

    Sure,

    Here you go:

    G90
    M82
    M106 S0
    M140 S110
    M190 S110
    M104 S220 T0
    M109 S220 T0
    G92 E0
    G1 E-6.4000 F3600
    G1 Z4.090 F12000
    ; process Process1
    ; layer 1, Z = 0.090
    T0
    ; tool H0.100 W0.528
    ; skirt
    G1 X-43.668 Y43.546 F12000
    G1 Z0.090 F12000
    G1 E0.0000 F1080
    G92 E0

    Now Im confused though. Am I supposed to slide a piece of paper or feeler gauge and lower the right amount to barely touch with the nozzle and send the G92 Z0 command to set that as Z=0? Or does the auto calibration do that with my bed.g file?


  • administrators

    I suggest you do either a G32 to auto calibrate before printing, or at least do a single probe (send the nozzle to 5mm above bed centre and execute G30). That will use the FSRs to establish an accurate Z=0 position. You can do either in your slicer start GCode.

    Your config-override.g file is not being used because you don't have a M501 command near the end of config.g. Whether you want to use it is up to you.



  • I have a similar issue, but I am running auto-calibration and bed mesh in my startup script and do not home between the end of the bed mesh and the start of the print.

    I still wind up baby stepping down .15mm at the beginning of each print, regardless of what I set my z-probe offset at...


  • administrators

    @wwmotorsports said in Z offset Not Doing Anything:

    I have a similar issue, but I am running auto-calibration and bed mesh in my startup script and do not home between the end of the bed mesh and the start of the print.

    I still wind up baby stepping down .15mm at the beginning of each print, regardless of what I set my z-probe offset at...

    Are you sure that increasing the G31 Z parameter by 0.15mm doesn't resolve that?



  • It appears that there was an error with the data in my config-override file not being used that was causing the issue. I deleted the config-override file and added the M501 command to the end of my startup script after the probing and the first layer height is perfect every time now. Thanks for the expert advice as usual!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.