Delta with duet-wifi and smart efflector



  • Need some help please with a home made delta I've built. I home all and its all good. Then when I send the command G30 I get this message, Error: Z probe already triggered at start of probing move. Any help would be grateful on what I need to addjust.

    Cheers

    Rob



  • Might want to post your config.g file to make sure you have all of the setting right.



  • Hi, hope this helps

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z200 E663 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z30000 E1200 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z2000 E1000 ; Set accelerations (mm/s^2)
    M906 X650 Y650 Z650 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 R0.4 H5 F120 T6000 ; Set Z probe type to effector and the dive height + speeds
    G31 P220 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    M557 R85 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S160 ; Set temperature limit for heater 0 to 160C
    M305 P1 T100 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    Cheers

    Rob


  • administrators

    Most probably a wiring error. Does the green LED on the Smart Effector flash when you power up and then go off? If so then the problem is likely to be in the wire that carries the output signal of the effector to the Z probe IN pin.



  • Thanks for the quick reply, yes the led on the efflector flashes twice when powering on.



  • And I will check the wiring output from the efflector down to the input of the board now and will report back.


  • administrators

    I just remembered something: are you using a Duet 0.8.5? If so then Z probe mode 5 doesn't work in older firmware revisions.



  • I have the Duet Wifi V1.03, and I have checked all the wiring which looked all fine until I got the multimeter to it to find one bad crimp on the input side by me?and all good now. The other question is as I power the machine up both the hotend and work cooling fans are at full bore until I slide them to 0 on the web controll. Any pointers would be great.
    And thank you David for pointing me in the Wright direction for the efflector

    Cheers

    Rob


  • administrators

    Normal practice is to connect the print cooling fan to the Fan 0 output and the hot end fan to the Fan 1 output. That way, at power up the print cooling fan will stay off; while the hot end fan (and Smart Effector LEDs) will turn on briefly, then go off unless the hot end is hot. This assumes you don't change the fan settings in config.g.



  • Ok plugs changed round fans are good now, the other problem is when I activate the hot end temperature is reading at room temp of 22.6°C, as the hotend starts to warm up the temperature reading comes down instead of going up and get this message,
    Error: Heating fault on heater 1, temperature rising much slowly than the expected 1.8°C/sec.
    Maybe I'm missing somthing somewhere



  • Ok so I'm still stuck with the temperature reading. Setup is as follows,
    Duet Wifi with a smart efflector on a Delta.
    My question is, I have put the PT100 thermister onto the E3D block and plugged it into the smart efflector, now off the efflector you have the 4 pin outs on the hotend temperature sensor T1, T2, T3, T4, and going onto the efflector behind those pins are two pads labled jumper for two wire, so on for two wire and off for four wire. Labled T1+T2 are paired and T3+T4 are paired. So which paired do I connect from and to where on the Duet Wifi? Also if it help I do have the PT100 board which looks like I can plug it onto the Duet. Which configuration would be more suitable for me, any help would be grateful.

    Rob


  • administrators

    Two choices;

    4-wire connection (best): connect pins T1, T2, T3 and T4 to one of the 4-way terminal blocks on the PT100 daughter board in the same order (it doesn't matter which end you start from). Remove the jumpers from the two pairs of jumper pins on that channel of the daughter board.

    2-wire connection: connect T2 and T3 to the middle 2 pins of the 4-way terminal block on the PT100 daughter board. Fit jumpers on both pairs of jumper pins on that daughter board channel.

    See the wiki for how to configure PT100 sensors in firmware.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.