Duet hangs after attempting to print without homing on delta printer



  • Hi,

    maybe a bug.

    I tried to print without homing my printer (by accident) and after that the Duet is unresponsible.

    What I did:
    M37 S1 -> start simulation mode, but without it happens too
    start printing a file that does not contain any homing moves
    after a few seconds WebControl will disconnect, and you cant connect again.
    Only a reset or power cycle will restore the Duet.

    I tried this with my DuetMonitor on the PanelDue serial port, so I can have a look with a logic analyser.
    Here are the screenshots:

    1. the first response to M408 after starting the print

    The 408 response goes to "pos":[0.00,0.00, and then comes a part of the error message 'efor homing the towers\nAttempt' and so on.
    The message 'Attempt to move befor homeing the towers\n' does not end with an 0x0a (LF) but with two ASCII character '\n'.
    I think the message will repeat for each G1 code in the file, but could not see it with the logic analyser.
    My suggestion is to send the message once and abort the print.

    2. after several minutes I took another look

    As you can see, the response is incomplete.
    I dont know what the WebControl gets back, but if its incomplete too, maybe thats the reason for the disconnect.

    Andre


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.