Bltouch problems with duex 5



  • I used to run my printer without an expansion board, and had the bltouch working properly. I have recently installed the duex 5 expansion board and connect the bltouch to the corresponding pwm port. Now when I run the same commands as before, I do not get any reaction from the probe. It is possible that I have it plugged into the wrong pwm port. I also wouldn't be surprised if there was an error in my configuration. FYI I have no heaters plugged into the duex.
    Thanks for any help,
    Ian
    Here is my config.g in case it is needed: {

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Apr 28 2017 16:37:23 GMT-0500 (Central Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M82 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    ;Tool settings
    M563 P0 D4 H1
    ;Dual z axis
    M584 X0 Y1 Z2:3 U3 E4 E5

    M667 S1 ; Select CoreXY mode
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X275 Y285 Z235 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z2 U2 S0 ; Define active low and unused microswitches
    M558 P5 X0 Y0 Z1 H5 F120 T6000 ; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only.
    G31 P50 X0 Y20 Z1 ; Set Z probe trigger value, offset and trigger height
    M557 X15:260 Y15:270 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M569 P4 S0 ; Drive 4 goes backwards
    M350 X16 Y16 Z16 U16 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z800 U800 E175 ; Set steps per mm
    M566 X900 Y900 Z12 U12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z600 U600 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 U250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 U800 E2000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M307 H0
    M307 H7 A-1 C-1 D-1
    M143 H0 S100; Set heated bed temperature to 100
    M143 H1 S260 ; Set maximum hotend heater temperature to 260C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P0 T100000 B4408 C7.269774e-8 R4700 ; set heated bed thermistor

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PIanCorexy ; Set machine name
    M551 PIcorexy ; Set password ;
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ;Zprobe bltouch

    ; Custom settings are not configured
    }



  • I think this section of the BLTouch setup would be relavent to you.

    It is required to invert the signal “I1” when using the expansion header pins and not the Duex to connect the BLTouch.

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_BLTouch

    So now that you are using a Duex5 you no longer need to invert. At least that's what I gather.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.