Mesh bed compensation and first layer issues


  • administrators

    If you haven't tried adding B1 to your M558 command yet then I suggest you do so, or else try probing with the bed heater off, in case the location of the bed heater wires/traces is affecting the trigger height.



  • OK, thanks, will give that a try next



  • I've read up on M558 B1 and tried it with the settings active (which I'll leave in place) but have also tested with the bed off.

    I got the same results - a gentle increase in the trigger offset up the X axis from left to right across the bed.

    So I've mechanically set the bed so that if I go to Z0 on any point on the bed I get the same amount of paper grip - i.e. no grip at all and then resistance after a drop in X of 0.01.

    This way I know the Z heigh is the same across the bed so hopefully the mesh levelling should now be able to cater for the difference in trigger heights across the bed..

    or not?


  • administrators

    If the Z probe trigger height (the difference in the height between the Z probe triggering and the nozzle touching the bed at that XY position) varies with the XY position, that suggests that the tilt of the print head varies with the XY position. The tilt affects the relative heights of the nozzle and the Z probe.

    If the Z probe is offset a long way sideways from the nozzle, then a bed that is curved severely could also cause the difference in trigger height.



  • @dc42 Makes sense, thanks.

    The bed is a high quality borosilicate glass and looks completely flat using a set square and other tools I have available.

    So I guess it is likely the tilt problem causing this - what can I do about it? Can I manually edit the heightmap file taking into account the fluctuations in the trigger to nozzle heights?


  • administrators

    @drammy said in Mesh bed compensation and first layer issues:

    @dc42 Makes sense, thanks.

    The bed is a high quality borosilicate glass and looks completely flat using a set square and other tools I have available.

    So I guess it is likely the tilt problem causing this - what can I do about it? Can I manually edit the heightmap file taking into account the fluctuations in the trigger to nozzle heights?

    Yes in theory, but it would be rather tedious to do.



  • @dc42 I'm a db developer so tedious data work is my thing 😉

    I tried one last thing - I think the bed is very flat so I've set it up so that the nozzle is at 0 at 5 key places and disabled mesh compensation and its printing the first layer much better now.


  • administrators

    That's great. Bed compensation increases wear on the Z axis, so it's better to avoid needing it by having a flat and level bed if you can.



  • @dc42 Yeah, I guess I was fixated on using all the technology but forgot to stand back and question whether it was actually necessary...

    Currently I'm removing any G29 commands from my gcode files and manually clicking the disable compensation buttons on DWC before each print.

    Is all that necessary or is there a better way to permanently disable bed compensation?


  • administrators

    Mesh bed compensation won't be used unless you invoke G29 or G29 S1 to enable it. So it doesn't need to be disabled, just don't enable it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.