Error installing firmware



  • Tonight I tried to update the firmware on my DuetWifi.

    I successfully installed DuetWifiFirmware.bin 1.16 and DuetWifiServer 1.03 but when I tried to update to DuetWebControl 1.13 my network connection never came back.

    I hooked up via USB and tried various ways to install the firmware with mixed luck. I still have the 1.16 main firmware running with no problem. Updating the wifi server is flakey using M997 S1, sometimes it works and sometimes it times out. Updating DuetWebControl using M997 S2 alway fails. The failure looks like this:

    SENT: M997 S2
    READ: Trying to connect at 460800 baud: failed
    READ: Trying to connect at 230400 baud: success
    READ: Erasing 3125248 bytes…
    READ: Erase failed
    READ: Error: Installation failed due to timeout error

    When M997 S1 fails, it looks similar.

    I get no response form a M552 S1 command if I try to bring the wifi up.

    Everything was working fine before I decided to upgrade the firmware this evening.

    Larry


  • administrators

    The "Erase failed" message suggests that either the WiFi module has failed or that you are running from USB power only and the USB 5V supply is inadequate. If you are trying to update using USB power only, either try a different PC (preferably not a laptop), or connect the USB via a powered USB hub, or power the Duet from 12V/24V when trying to do the update. Otherwise, ask your supplier for a replacement Duet WiFi.



  • I tried both with and without the 24v supply. I'll contact Filastruder. Thanks for the quick reply.

    Larry



  • New board came on Friday. Just got it installed and everything is back up and running with the latest firmware.

    Thanks for the great support!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.