Suitable webcams for displaying progress in the webui?


  • administrators

    Thanks, that's very useful information. I have a Zmodo camera that I haven't managed to use with DWC. I'll try a port scan on it.



  • @dc42:

    Thanks, that's very useful information. I have a Zmodo camera that I haven't managed to use with DWC. I'll try a port scan on it.

    in addition to the ones listed in the ispyconnect database, there is a bunch or stream URL's for zmodo camera's here too that might be useful? http://www.camera-sdk.com/p_228-how-to-connect-to-your-zmodo-ip-camera-onvif.html

    Soon as you can get a stream in your browser you're good to go and add it into DWC 🙂



  • Thanks crash69 I have one on order now…


  • administrators

    I finally got round to getting my Sannce I21AG web cam integrated with DWC. Here's the sequence I used:

    • I connected the camera to my WiFi network using the smartphone app. You select the wifi network and enter the password on the smartphone app, then it sends them as a sequence of tones through the smartphone speaker, which is picked up by the microphone on the camera.

    • After connection, I configured an admin password and also a user-mode ID and password.

    • I downloaded and ran http://www.sanncegroup.com/document/IPC/I21AD/tool/Search_tool4.2.exe. That told me the IP address and port number to use, in my case they were 192.168.1.122 and 19750. I don't know whether the port number 19750 is fixed for this model or randomised.

    • I entered this URL in DWC:

    http://192.168.1.122:19750/snapshot.cgi

    I checked "Do not append extra HTTP qualifier" (I don't know whether this matters or not).

    Firefox asked for a login ID and password, so I gave it the user-mode ID and password and told it to remember them.



  • Has anyone managed to get a camera to work with Chrome or Edge? On my Win 10 setup these browsers both see the stream and want to save the video stream to a file defaulting to videostream.cgi rather than display the stream.

    I understand that Chrome used to work but an upgrade some time ago killed this functionality so I'm trying to find out what I'm missing or whether I need to get FireFox.

    This behaviour happens both when I set the browser to access the camera stream directly and when I set the URL in DWC.


  • administrators

    I have my Sannce camera working with Chrome, using the same settings that I described above for Firefox.



  • Thanks, David, it must be something weird on my Windows config or Chrome installation. If I solve it, I'll report back for others.



  • I use the IP WebCam app on a cheap phone. It gives you the IP address to use after it is setup and running. Just have to put /video at the end of that IP in DWC.



  • Thanks number40fan. The weird thing is that the stream works (I can view it in VLC, for example) yet when I connect to it in Chrome (or Edge) whatever I add after the IP address and port (like /video in your example) the browser opens a 'save as' dialogue box and wants to save to that name!

    So http://192.168.0.111/videostream.cgi?user=xxxxx&pwd=yyyyy gets me this https://drive.google.com/file/d/0B8OcCwBLJgXFcXRaNk1PdWdiYkE/view?usp=sharing

    Edited to add: To be clear, this is not a DWC issue, it is something with my browser or PC configuration and DWC inherits the problem.


  • administrators

    I didn't use ?user=xxxxx&pwd=yyyyy at the end of the URL, I left them out and let FireFox ask me for them the first time.



  • Thanks, David, tried that too with the same results. There is clearly a setting I'm not aware of - I'll keep looking.


  • administrators

    videostream.cgi is wrong, that's for RTSP which can't be displayed in any browser. Use snapshot.cgi.



  • That just tries to save as 'snapshot.cgi' -whatever text I use there, with or without the .cgi or any other extension, is used for the filename to save as.

    I'll ask for help in the Chrome help forums next. Thanks for your help.


  • administrators

    Which model of camera do you have?



  • Various - I run a CCTV system called Blue Iris and have a number of IP cameras. They use a variety of IP ports and settings. Tried them all and as I say, they work in Blue Iris and in VLC but not in Chrome or Edge.


  • administrators

    Not all IP cameras provide the facility to return a jpeg still image. We'd love to support RTSP streams, but it's not possible since Google removed the support from Chrome. The programs that camera makers supply to access your camera from a browser send the RTSP stream to a cloud server, which then provides a HTML5 stream for your browser. That's why they make you open a cloud account first.



  • Thanks, David. These cameras supply RTSP and a series of still images over port 80, 81, or various other ports. To confirm this is a browser issue, I set up the Blue Iris webserver to stream video as a series of images. Although very CPU intensive on the Blue Iris server and not a permanent solution, it allows me to configure things rather than guess what the camera is sending.

    Opening the web page displays the image in a series of jpg files as this snippet of code from the Inspect element option shows (the 'time' number increments too fast to read as the 'video' is displaying):

    [[language]]
    ![](/image/Camera1?time=116339)
    
    

    Despite this, if I try to capture this stream in my browser direct, it tries to save it. Using the same page URL in DWC does not work - it just shows a blank white box where the video should be.

    I've taken the path of least resistance, though, and ordered a Sannce camera!



  • Hi All

    With the sannce camera you can add the user/pass in the url field in DWC as follows:
    http://user:pass@camip:port/snapshot.cgi

    if you have an @ symbol in your password change it to %40

    Works on Firefox anyway..



  • Based on DC42's experience with the Sannce camera, I bought 2 to test. I finally, after a little fiddling, got it to work just using the URL DC42 provided.

    The port varies, as mine was different than DC42's example. I'm not sure if that's because the camera was on a different firmware revision, or if it is random. In any case, the app linked to showed not only the IP but the port as well.

    I wasn't able to use the solution briangilbert suggested, though I am running Chrome, not FF.



  • yes that is true for chrome try adding this to the end of your Chrome URL

    ?loginuse=xxxxxxx&loginpas=xxxxxxxxx&resolution=32

    such as 192.168.0.120:18912/snapshot.cgi?loginuse=xxxxx&loginpas=xxxxxxxx&resolution=32 (still need the http preamble)

    Doug

    PS change the IP and Port to match yours.


Log in to reply