Is there RepRap Software End Stop Protection similar to Marlin ?



  • In Marlin you would need to disable this protection before you could use your Z Axes probe to set the Z=0 Location.

    At the moment I cant get my Z Probe to lower more than 5mm to trigger the Z Probe.

    It looks like RepRap thinks that Z = 0 in its current position and wont go below that point to even trigger the BL Touch

    ... looking through the documentation now the G91 command do not seem to remove software block



  • Found some hints at the problem in the logs

    M120
    G91
    G1 Z-10 F6000
    M121
    Error: G0/G1: insufficient axes homed
    Error: Pop(): stack underflow!

    I must admit I am absolutely hating RepRap Firmware at the moment.
    Its one of those things where some bright spark try's to make things simpler but in the process causes more problems by removing transparency (dumbing things down) and denying people access the logic of what is happening under the hood!

    Its taken me 10 days ti do something that would take 1 day with Marlin.

    With Marlin you get everything there in front of you;

    1. The actual code
    2. Really good description of the settings all there in front of you
    3. A chance to see how the variables are actually being implemented
    4. No changes to double check ... the actual code is there absolute!

    ... none of this RepRap firmware crap of;

    1. Having to look up the description of the GCODE commands on a separate web page.
    2. Having to working out if your firmware actually supports a load of deprecated changes that somebody has decided to change.
    3. Guessing on how somebody has thought best to implement the variables you have just set with GCODE.

    #bangsheadontable
    #reprapfirmwareistheworkofthedevil
    #wishduetsupportedmarlin



  • flipping heck! In the BL Touch documentation I was directed to it failed to mention a vital piece of information.

    Note there are two Z End stop Pins;

    Z Stop (Normal)
    Probe Molex Socket End Stop Pins (Z Probe In & Grnd)

    If you have normally High End stops defined you have to have specifically set the Z End Stop to Probe in a separate line stanza ;

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops
    M574 Z1 S2 ; Set z probe endstop

    Previously I was thinking that I had to disable the normal Z end Stop to stop it overriding the Z Probe End Stop;

    M574 X1 Y1 Z0 S1 ; Set active high endstops

    when that did not work I thought ,,,, well maybe the code is overloading the normal End Stop GCODE and you had to set it to normally High and not disabling it;

    M574 X1 Y1 Z1 S1 ; Set active high end stops

    This did not work and because it was set to normally High and the Z Stop was not connected ..... therefore the printer always thought it was at Z=0!

    You need both;
    M574 X1 Y1 Z0 S1 ; Set active high endstops
    M574 Z1 S2 ; Set z probe endstop

    This is the problem with RepRap ,,,, you are left guessing at what the developers had decided to implement and when you have poor documentation ... it causes chaos !!

    Bad RepRap Firmware 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.