Unable to change extruder motor direction



  • Hi all,

    I have been using duetWifi for the last few weeks without any issues. I have been experimenting with extruders, so I was changing motor direction without any issues until today.
    It does not matter if I set the motor to Forward or Backward or if I manully edit config.g file the motor does not change its direction.

    Anyone experienced this ?
    Any ideas ?

    Thank you



  • Are you sure you are uploading the file after the manual edit? In the web interface, if you go into "settings" then "system editor", then look at the config.g file, does that show that the changes have been made?


  • administrators

    If at the same time the extruder torque has dropped a lot, then you may have a bad crimp connection in the stepper motor cable, or possibly a faulty motor or faulty driver.



  • Actually all prints from yesterday are under extruded, so I have switched the extruder, but this one needs the stepper to run in opposite direction. Is it possible that the underextrusion was caused by faulty driver ? So the direction change does not work because of that as well ?

    I have tried editing the config.g file, set the direction, restarted duet and tested then set it again to opposite direction, restarted and tested again but the stepper goes same direction.


  • administrators

    You don't need to restart, just make sure you know which driver number the extruder is connected to, then send the appropriate M569 command. For example, M569 P3 S0 and M569 P3 S1 will select the two alternative directions for the motor attached to the E0 motor output.



  • Thank you for the reply.

    I think I have figured it out, the driver is fine (I think) as I was able to change the direction finally.

    This is what happened:

    I have moved the extruder from E0 to E1 motor output.
    I have set the E0 drive to use 4(E1) Motor driver
    The issue is that configurator.reprapfirmware.org generated config for E0 instead of E1, I do not know if that is a bug or a feature, but setting manually M569 P4 S0 did the trick.

    Thank you everyone for you support.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.