Print becomes thinner when the heated bed is on



  • I have a pretty odd issue that I initially thought was z wobble and then potentially current being induced by close cables when the heated bed turns on, but I'm not so sure.

    I'm getting a very consistent change in print whenever the heated bed turns on - this seems to manifest as the print becoming slightly thinner while the bed is on. Over time this looks like very slight horizontal ripples in the print.

    I don't think it's z wobble as I can see it happen as the heated bed turns on and when printing a cylinder the radius reduces pretty uniformly rather than shifting in one direction. I don't think it's induction through the heat bed cable because I've separated the cables as much as possible and it's still happening. Leaving the heated bed off eliminates the issue entirely.

    Any ideas?

    I'm on a Duet Wifi firmware 1.20 with a CoreXY setup and 24V electronics - the heated bed is connected directly to the Duet.



  • PCB heat beds are known the change shape and flex during heating cycles.

    Are you using PWM or bang bang for the bed?


  • administrators

    This is fairly common when using bang-bang control for the bed. When the bed heater turns on, the VIN voltage at the Duet drops. How much depends on the PSU, the resistance of the cables between the PSU and the Duet, and whether the VIN terminal block screws are tight. You should be able to see this drop by monitoring the Vin value displayed by DWC when you turn the bed heater on from cold. The reduction in voltage can cause a reduction in extruder heater power, which results in a drop in extrusion temperature until the PID catches up.

    Two suggestions:

    1. Send M307 with no parameters to check what heater model values you are using. If the V parameter is zero then heater voltage compensation is not being applied. So run heater tuning again and make sure you copy the V value across to the M307 command in config.g along with the A, C and D values.

    2. Run the bed in PID mode.



  • @dc42 said in Print becomes thinner when the heated bed is on:

    M307

    Thanks for the info! I strongly suspect you're right and I'm printing a cylinder just now to make sure (I can already see the bed led flickering away instead of going on and off in longer intervals)

    However, when I ran M307 H0 to check the bed mode it came up with default values, which I thought was odd because I had definitely ran pid tuning on the bed and used M500 to save the results. So I checked config-override.g and could see the M307 values the pid tuning had spat out (including a voltage change value).

    M307 H1 brought up the hotted values in the override correctly but M307 H0 didn't bring up the bed?

    I've worked around this by copying the M307 H0 values into my config.g proper and that seems to work (calling M307 H0 now brings up the saved values).

    That's not intended behaviour is it?



  • That looks like it’s done the trick, thanks!

    Left cylinder printed with default bang bang for the heated bed and then with the Pid tuned values for M307 (and voltage compensation) on the right 🙂

    0_1524306499437_D7EFE4EB-392A-437E-927F-465D06A07168.jpeg


  • administrators

    I'm glad you solved it. Did M307 H1 show a V parameter when you ran it?



  • @dc42 M307 H1 shows 0 for the V parameter, while M307 H0 shows 23.7 (it sits at about 24.2 when the bed is off based on the machine status).

    Is that an issue?


  • administrators

    The V parameter for H1 is the critical one. Without it, there is no extruder power compensation for variations in the supply voltage. With the correct compensation, even with bed heater bang-bang control there should be no banding.

    So I suggest you run extruder heater tuning again. Last time you ran it, you must have been running older firmware that did not provide compensation of extruder heater power with variation in supply voltage.



  • Thanks for the follow up. I’ve run tuning again for the hotend and M307 H1 is showing a value for V now (24.2) - presumably that’ll improve things even further after ensuring the bed was running with pwm?

    And I guess M307 H0 being ignored in the config override must be potential a bug?


  • administrators

    I've just tested using M500 to save new M307 H0 values in config-override.g and then rebooting, and it's working for me.

    Do you have M501 at the end of config.g, to invoke config-override.g?



  • M501 /facepalm.

    Yeah that was missing, and had it been there this whole time the OP issue wouldn't have happened 😛

    Massive thanks, pid tuned values loading up from config-override.g correctly now and both H0 and H1 have voltage values in there now as well!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.