Precision Piezo Orion - anyone got a working config?



  • Hey. I cant seem to figure out how to properly get my orion to work.
    The sense seems ok, i can barely touch it and it triggers, however
    when probing it does not sense anything untill it has bendt my carriage up like 10mm.

    Ive tried different probe speeds and both analog and digital with same results.

    im stuck:P



  • I had a similar problem and was advised that this was caused by the 4 screws that hold the top/bottom together being too tight. I have slackened mine off now until they are really quite loose and it is triggering OK by upward pressure rather than being triggered by a transient tap.

    Having said that, I am still not happy. I tried to use it today and after the G30 at the start of the print the nozzle went too low. Whereas yesterday with the same config it worked fine. I'm keeping an open mind at the moment but can't say that it's been easy so far.



  • I use:
    M558 P8I1 H5 R0.5 F150 X0 Y0 Z0

    in endstops I have:
    M574 X1 Y1 Z1 U1 E1 S1 ; dual Z (Z & U) endstops, and filament out E1

    I do NOT use my probe as an endstop, but use it for bed compensation, if you are using as an endstop, I think you should have a second M574 Z1 S2, and remove the Z from the other M574...

    Have you tried a G30 yet? As per the docs:
    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe &
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe
    you should try a "dry" run, from a good distance above the bed first, and tapping the probe to make sure it registers, before trying against the bed (and ploughing into it when it doesn't work first time!)

    I had some issues setting up, had to increase the sensitivity, even though I could trigger with my finger, and there are also some minimum recommended speeds, below which the "tap" is not registered correctly

    @burtoogle screws should be just tight enough to not allow wobble, as far as I can tell... having said that, mine are quite firm

    hope that helps!
    Andy
    🙂



  • I think I have found the reason why the probe wasn't working right, as I had the M558 and the G31 in the wrong order. RTFM!

    To specify which probe you are setting parameters for, send a M558 command to select the probe type before sending the G31 command, or use the T parameter.

    So, fingers crossed, it's working OK now.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.