First axis homing test



  • Hi,

    I'm building a Cartesian printer 'from scratch' by copying a lot from an ormerod setup. I've only hooked up the Y-axis with endstop and I've tried the homing sequence.
    When I home the Y-axis, it executes all steps from the homey.g file correctly but in the web-interface, the Home Y button stays yellow. If I move the y-axis, the Machine Status on the top right also keeps saying 0 for Y-axis. It does however know my axis max and min value with respect to the homed 0 position, and it does not exceed them… so I guess the homing result is OK, but it's just not shown in the web-interface. Is this because I only have one axis connected and nothing else yet ? Or do I need to tell the firmware that Y-axis homing is finished ?

    You can see my setup here : https://wordpress.com/read/feeds/51775069/posts/1238478437

    [[language]]
    G91                ; relative mode
    ; G1 Z4 F200         ; raise head to avoid dragging nozzle over the bed
    G1 Y680 F4500 S1  ; move up to 680mm in the +X direction, stopping if the homing switch is triggered
    G1 Y-4 F1000        ; move slowly 4mm in the -X direction
    G1 Y10 F100 S1    ; move slowly 10mm in the +X direction, stopping at the homing switch
    G90		   ; back to absolute mode
    G92 Y647	   ; this is 642 + 5mm 		
    G1 Y0 F45000	   ; now go to 0
    G91                ; relative mode
    ;G1 Z-4 F200        ; lower the head again
    G90                ; back to absolute mode
    
    


  • In config.g you did configure the y endstop is at max and have the bed size configured?

    Wordpress site asks for a password, you need to provide a public url.


  • administrators

    It sounds to me that your Y endstop switch is not working or not configured correctly. Use the Machine Properties page of DWC or the M119 command to check it.

    You don't need the G92 command in your homey.g file if you have set the Y axis upper limit to 647mm in the M208 command in config.g.



  • Thanks for replying. I must admit, at first, I did have the forward and backward thing wrong. I was so focused on they-axis carriage going left and right, assuming that utmost left was 0, and utmost right was 642 + headroom. ( the bed area would be x200 y642) that I was constantly thinking left = 0, right is 642.. I know, it should be different if you look at how the bed is situated with respect to the nozzle. I want to use 5mm headroom left and right.

    so for now, what I have in config.g which is relevant for y-axis is :
    M569 P1 S0 ; Drive 1 goes backwards
    – because going left means adding mm
    M574 X0 Y2 Z0 S1 ; set homing switch configuration
    -- the end stop is located left, but the bed moves to a fixed x-z gantry like the ormerod printer, so I assume the Y axis endstop switch is at the high end ( Y2 ) and it is normally closed.
    M208 X200 Y642 Z200 ; set y-axis maxima to 642 mm
    M208 X-8 Y-5 Z-0.5 S1 ; set y-axis minima to -5 mm

    if I use the M119 code , I get the correct reading for endstop 'at max stop' or 'not stopped' when the switch is activated or not.
    The machine properties page of dwc nicely shows this as well 'endstop hit yes' or no, which is accurate

    In the config file, I have set the min and max for travel along the y-axis
    My plan is to home towards the y-axis endstop, which would put the nozzle at 647 mm. moving 5mm to the right is 642 mm, which is the far end of the bed as far as the nozzle would see it...

    The homey.g file does exactly what it should do... so I'm very happy... it moves to the left, hitting the endstop, going 4 mm back to the right, disengaging the endstop, and then going back to the left very slowly to hit the endstop again. I thought that sending the G92 Y647 command in the homey.g file would let the firmware know it's location ( max bed distance + 5mm headroom ) After that, it moves to the right so that the nozzle ( which is not yet present ) would point at 0 on the bed.

    If I give instructions to move, it works, it also obeys the minimal and maximal value for the axis so I believe everything worked. It's just that the web interface doesn't show that homing worked by changing the color of the button, and it also does not report the position of the y axis back to me... this is always 0.

    I just thought there might be a command to tell the web interface that homing succeeded... πŸ˜•

    This is the general url of where I post my adventure.. I'm under the impression this is posted public, so maybe this url will work beter. I currently don't have an idea on how to post links to pictures that would stay there for a long time...
    https://djnoyz.wordpress.com/



  • wow.. checked and double checked config yesterday without testing … fired up this morning to test and everything is now working like a charm... πŸ˜• πŸ™‚ Home Y button turns blue, and when I move the Head Position indicates the correct values.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.