Calibrating Delta



  • Hi,

    Lots to learn...

    HW Config:
    -- DUET3D-E
    -- PanelDUE
    -- Smart Effector + E3D/V6 HE

    I ran the Configurator 'Wizard' to generate the g files. I set the config for 'Smart Effector' and an 8 pt auto-cal probe process.

    Running auto-cal, everything works fine, except out around the edge of the max print-radius, the nozzle, dives slowly, pushes into the bed, so much so that the effector tilts, the TOUCH indicator doesn't illuminate and CONSOLE emits an error message: "Error: Z probe was not triggered during probing move." After effector retracts, the TOUCH LED illuminates. While probing around aound the inner area of the bed, the effector dives, probes, stops, retracts, TOUCH LED illuminates, and doesn't emit an error msg...probing appears to function properly.

    So, I've been reading the DUET3D wiki calibration articles, and am calibrating the Smart Effector Z-Probe via URL: https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer#Section_Measuring_the_trigger_height

    Section Dynamic Test:
    -- "Send G30"
    -- I hold a DigiKey PCB reference ruler underneath the Hot-End nozzle, it doesn't trigger, even to the point of substantially bending the ruler, and if I 'snap-tap' the nozzle, I see the Smart-Effector (GRN LED) 'TOUCH' LED momentarily illuminate, and the CONSOLE annunciates: "Error: Z probe was not triggered during probing move"

    Is this normal or is there an issue?

    Thanks in advance

    3mm



  • @3mm

    What is your M558 F set to? It needs to be 1000+( M558 P5 R0.4 F1000) for the tap to be 'snappy' enough(part of testing the probe before you use it so you're not diving into bed too fast if it's not working) .

    If it goes into bed too slow then it won't trigger.

    When I was setting mine up I found that diff probes do different speeds so the 'Auto calibration delta' doesn't have the settings that the Delta smart effector uses. Easy to get the wrong value there.



  • @Mysta

    Thanks for the reply & info...

    Selected contents of file sys\config.g
    with Mysta recommended mod, which
    now is 'snappy'. Nozzle literally 'clicks' as
    it taps the bed, but not strongly, and there
    are no error msgs being emitted!! 😮

    ; ---------- Smart Effector -----------
    ; Z-Probe
    ;M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated, dive height, speeds as gen'd by cal-wiz --3mm
    M558 P5 R0.4 H10 F120 T6000 ; Set Smart-Effector 'Z probe', recovery time, dive ht, speeds --3mm
    ;G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset, trigger ht --3mm
    G31 P100 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset, trigger ht --3mm
    M557 R115 S20 ; Define mesh grid
    ------------ end Smart Effector -------

    Kewl

    Lots to learn...

    Thanks - 3mm



  • @3mm The new one still shows F120, but also in another thread DC42 mentioned in new firmware we can use P8 for smart effector probe which is more accurate instead of P5. I haven't tried it yet.



  • @Mysta,

    Oops, sychronization error, I changed the value from F150 to F1500, and it definetely is behaving more akin to what I suspect it should do. Thanks.

    Got a new issue, the bed temperature readout never drops below 210°C with the bed set to 'off' via the web console. I've checked, both the bed thermistor and the bed are attached to the DUET-E board as referenced to the drawings. I've tried setting the temp to the lowest offered setting in the DLB (drop-down-listbox), but temp won't descend below 210°C. I've also tried disabling the bed by sending M140 H0 S-100 which supposedly disables the bed heater because it is a negative value. Perhaps the MOSFET is shorted?

    Got any suggestions?

    Thanks for sharing your knowledge.

    3mm


  • administrators

    @3mm said in Calibrating Delta:

    Got a new issue, the bed temperature readout never drops below 210°C with the bed set to 'off' via the web console. I've checked, both the bed thermistor and the bed are attached to the DUET-E board as referenced to the drawings. I've tried setting the temp to the lowest offered setting in the DLB (drop-down-listbox), but temp won't descend below 210°C. I've also tried disabling the bed by sending M140 H0 S-100 which supposedly disables the bed heater because it is a negative value. Perhaps the MOSFET is shorted?

    Do you mean that the bed temperature reads 210C as soon as you turn the printer on (meaning that the thermistor isn't reading correctly)? Or do you mean that the bed heater turns full on when you turn the printer on, and the indicated temperature rises gradually to 210C?



  • @dc42

    Thanks for the other replies & re; the SE Z-Probe cal question.

    Re; the bed heater issue. Yea, I was fairly tired when I wrote, my info wasn't too accurately described...

    When I power-up the cold printer, the web-console BED temperature readout indicates ambient, but after a few moments, the readout depicts that the heater is gradually beginning to warm, although the status indicator depicts that the heater is OFF, and after a period of around 15 minutes the BED temperature readout shows around ~220°F/105°C. As the bed heater temperature is rising, the thermister & readout tracks the heat. I have verified the temperature by measuring using an imaging pyrometer (Fluke pistol w/LASER pointer IR digital temp meter), which is within 1 or 2 degrees of the web-console temperature readout. I have tried to command the BED temperature down to 55°C, but temperature does not decrease, however, I have commanded the BED heater to a higher temperature, which it does do, such as from 105°C to 110°C which it does do. If I command it to rise from 110°C to 120°C it also does that. I command it back down to 0°C, the temperature will decrease back to ~110°C.

    Am I missing something, a G-Code or something? In any case, I'm gonna stick a scope on it and see what I can see. I looked at DUET3D V1.03 diagram and I tracked down a source for the FET, $1.75 from DigiKey. I notice that there is an electrolytic cap across the drain and source leads, maybe its leaky? I recently fixed a Kenwood TS-440S ham transceiver, it was pulling down a 13.8Vdc 25Amp power-supply to 3V, because of a shorted input filter cap..

    Any comments will be appreciated.

    Thanks - 3mm


  • administrators

    It sounds to me that either you have a short between the bed heater and ground, or the Duet is faulty. Please can you:

    1. Check whether the bed heater LED turns on as soon as you power up the Duet. If so:

    2. Turn the power off, disconnect the bed heater from the Duet, also check that the bed heater terminal spills on the back of the Duet are not shorting to anything underneath.

    3. Apply power again and check whether the bed heater LED still turns on. If so:

    4. Power off, remove the SD card from the Duet, then power up the Duet and see whether the bed heater LED turns on.



  • @dc42

    Bed Heater LED? Card edge E0?

    3mm


  • administrators

    The bed heater LED is next to the bed mosfet, between the VIN and bed heater terminal blocks.



  • @dc42

    On the card edge, the two Heater LEDs E0 and E1 remain off, although they flash on momentarilly and then off. They stay off.

    If I command Heater1(T0) = ACTIVE & setting 180°C LED E0 illuminates,

    If I command Bed heater = ACTIVE & set any value LED E1 does not illuminate, yet power-supply fan ramps up speed on any value above 110°C, still the LED E1 remains unlit.

    I will (yuch) pull all the connectors off and dismount the board to get a peek see underneath, although I did a fairly thorough check prior to mounting. I presume that 'spill', you intend solder flow & possible splashes?

    I'll let you know. Thanks.

    3mm



  • @dc42

    We were cross writing, so I missed your info re; LED placement, and as I have an external (not underneath heat-bed) enclosure, I can not see the LED with the lid mounted. But preliminary, the red LED is illuminating on power-up. I'm disconnecting the heater wires now..

    3mm



  • @dc42

    Hi,

    Ok, I pulled the board, carefully checked the bottom and top for splashes, hairs, etc, I saw nothing obviously wrong.

    I performed your 'tests' and the red Bed LED remains illuminated, with or without Bed heater connected or with the SD card

    Yep..

    3mm



  • @dc42

    I reviewed the correct schematic (v1.02 as marked on the top silk), and I can't seem to locate which pin of the SAM drives the bed heater?

    Worse case, I may have to ship the board back, but because I've waited nearly a year to use it, its likely out of warranty. Rather than ship the board..two weeks back, two weeks return, a whole month is fried, I'd rather either fix it myself or use an external bed driver if I can. But I don't see where the pin comes out on the expansion connector. What are your thoughts on that? Any recommendations for an external driver?

    Thanks - 3mm



  • @DC42,

    Ok, referencing the sch, I found the Bed (HEATER0) signal, I initially missed U11, another clever strategy.

    HEATER0 & BED_PWM come on TP6 & TP9 but I don't see that either signal are routed to the Expansion connector. Am I missing something again?

    Thanks

    3mm


  • administrators

    The on-board heater signals are not routed to the expansion connector, but there are 5 additional heater control signals that are. They are 3.3V level, active low. So you should be able to use one of them by connecting the input of a good DC-DC SR (see recommendation in wiki) between +3.3V and your chosen heater signal. Or, if you are not using the E1 heater output, you could connect the input of your SSR or a mosfet switch to that output. Use M140 to re-assign the bed heater to a different heater number.

    You can measure the voltage on BED_PWM (TP9) to help identify where the fault is. It should be 0V when the heater is commanded off, and around 5V when it is commanded on.

    Which country are you in?

    HTH David



  • @dc42

    Hi...yeah, I'm must be slipping, I re-looked at the sch and completely missed how the LED is wired. Fault can't possibly be caused by the cap being leaky. I'm gonna have be a lot more careful in determining the problem. It could be caused by an interlayer short, perhaps in the area of the sink-thru's.

    I do have a hot rework station, and the FET is available.

    I'm in California, USa. I got the board from FilaStruder. They are good guys.

    I'll poke around with scope later today when I get back from my errands.

    Thanks for your help.

    3mm



  • @dc42 said in Calibrating Delta:

    The on-board heater signals are...3.3V level, active low....use one of them....with...a good DC-DC SR (see recommendation in wiki)...

    ...use the E1 heater output...to...connect the input of your SSR...to that output. Use M140 to re-assign the bed heater to a different heater number.

    HTH David

    David, et al,

    I acquired an Auber Inst SRDD-100 (I've used their SSRs for other things, I found them to have good prices and quality parts, thx for the referral). I installed the SSR 'puck' atop (w thermal paste) to my 350W 12Vdc Mean-Well switching power-supply after degreasing the area, I don't think it needs much of a heat sink, and the switcher does have an internal fan which kicks on when things get warm inside. I used 12Ga stranded Cu wire for the SSR and the 180W 12Vdc (0.8Ω) round PCB/aluminum bed-heater assembly wiring.

    It works, though not well. I've expended a fair amount of time doing the auto-temp tuning which has it working, sort-of?? If I enable PID, it never attains 110°C in less than 10 minutes, and then does so, barely. I can't cause to attain 120°C. I fiddled around with the PWM setting until the system would not emit error: heater-fault.

    I noticed that the DWC displays 'Cal Vin = 11.5'. I have multipe DVMs, a Fluke, an ExeTech and an HP bench version, all measure 12.10 Vdc. I don't know how that calibration reference is derived, or if its sub-normal. In any case, I double checked all my wiring and Voltages, at the Power-Supply, at the screw-terminals on the DUET-E (v1.02) and on the bed terminal-block. The Voltages are ok. I also double checked my power-budget, I should have around 100W over-head, and when all the steppers are running, and both heaters are heating, the power-supply Voltage does not sag. The AnyCubic factory did not include the heat-bed with their version of the AC Kossel Linear-Plus that they sold me, but I bought the bed later from them. So it should work??
    If I run the bed heater in bang-bang, it heats up, but then its dodgey and I can not attain 120°C.

    The G/M codes are very functionally capable and it seems that I'm missing something, unless the bed is just somehow bad?

    Just an FYI...thx

    3mm


  • administrators

    What type of bed heater is it? If it's a PCB bed heater, those are frequently under-powered. I think one of the problems is that the Chinese manufacturers don't control the copper thickness very well, so the heating power varies a lot between different samples of the same PCB heater.

    If your PSU has a voltage adjustment pot, you can turn it up to get extra bed heating power.

    The VIN voltage measurement on the Duet uses 1% tolerance resistors in the voltage divider, and the +3.3V supply as the voltage reference. The output of 3.3V regulator chip has a tolerance of +/-2.5% worst case and +/-0.5% typical. So even if you are really unlucky, the voltage reading shouldn't be significantly more than +/-4.5% off.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.