Issues addressing Duet 0.6



  • Hi everyone, it's my first time posting on this forum although I have been toying with a couple of printers for a few years now.

    I've got an old Duet 0.6 that's been laying dormant in a drawer for the last few years so I decided to build a Delta to put it in. The printer is 95% built so I decided to test the electronics out...but I can't get this board to connect properly.

    It will connect to YAT and Pronterface and I can get a response from the board but it doesn't seem to want to address itself properly either using DHCP or if I give it a static IP. I just get the following responses:

    0_1525119339753_YAT SCREEN SHOT.PNG 0_1525119350377_KNOWN IP ADDRESS.PNG

    I know that the static IP address is valid as I pulled it from the config file on another of my printers and that works fine, (I wasn't running them both together so there is no conflict). I've tried different addresses too and I just get the same response.

    Pronterface won't allow me to operate any of the motors and I can't get the web control to open.

    I'm a bit stumped and don't really know where to go with this now so any help you can give me will be gratefully received.

    Thanks
    Jon



  • try posting your Config.g file for us to look at?



  • My Config.g file is as follows:

    ; Configuration file for Duet 0.6 (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Apr 30 2018 14:55:42 GMT+0100 (GMT Summer Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R162 L360 B135 H302 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PDELTA ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M92 X80 Y80 Z80 E663 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 R0.4 H5 F120 T6000 ; Set Z probe type to effector and the dive height + speeds
    G31 P100 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    M557 R100 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R1000 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R1000 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


  • administrators

    Firmware 1.21 doesn't allow normal axis movements prior to homing by default, unless you send M564 H0 first. That's probably why your axis motors won't move.

    Do the LEDs in the Ethernet connector light up when you connect it to your router?



  • Yep, I managed to figure out the motor issue late last night thanks.

    I got Pronterface to prove that all the motors will run and that I can get Hotend temp. etc, which was a relief as I wasn't 100% sure that I hadn't fried the board years ago and that was why it had ended up in the drawer.

    I also realised I was getting an error on my PC Ethernet port saying that the port had no IP address. To try to rule this error out I've just tried connecting the board to another PC that I run my other printer on (Duet 0.8.5 connected directly to PC via Ethernet cable).

    I get exactly the same result.

    All communication seems to be over the USB only, I can't get any response when trying to just use an Ethernet cable linking the Duet to my PC.

    I see both LEDs illuminate on the Ethernet connector but they are on constantly, no sign of data transfer.

    I just tried connecting the board to the router over a Powerline connection and I see blinking LEDs when I try that.


  • administrators

    Bear in mind that the Ethernet socket on the Duet does not do auto-crossover, therefore if you connect it directly to a PC then you may need to use a crossover cable, depending on the PC.

    It's not uncommon for Duet 06 boards to develop Ethernet faults caused by imperfect soldering of the PHY chip. Reflowing that chip with hot air usually fixes it.



  • Thanks very much for the info.

    I think I am going to try re-flashing the board with the same firmware as I have on my other printer.

    I know the other printer works, so in theory I ought to get the Duet 0.6 board to work in the same way if I use exactly the same firmware and SD card image. It may help me narrow down the issue anyway.

    I don't really want to try re-flowing the chip if I can help it.



  • I don't suppose you have a copy of RepRapFirmware-1.09r-dc42 do you?


  • administrators

    You can get old versions of RRF from GitHub because the complete release and source code history is in there.



  • Thanks for getting back to me so quickly. I had already had a look on GitHub but I couldn't find an old enough version, I managed to find a copy of 1.09 on my PC though so I used that to re-flash the board.

    I copied the SD image directly from my Ormerod and tried that in the Duet 0.6 and it worked nearly perfectly.

    The thermistor temps were all out but I guessed that was due to the difference in resistor values between the two boards. Once I'd amended the config file they were ok.

    The hotend fan no longer ran though. I put a meter on the board and the pins were showing no voltage. It worked fine yesterday. Is the pin assignment different between the 0.6 and the 0.8.5?

    Getting back to the original issue I was having it is obviously something within the software that is causing the problem. More specifically I'm sure it is something to do with the IP addressing.

    The config file I pulled off my Ormerod has a static IP that actually bears no resemblance to the IP addressing of anything else on my home network and yet it seems to work. I think it came from when I originally set up my Ormerod many years ago. I can get my Ormerod to connect with the Web Control if I plug the Ethernet cable straight into the back of my PC or plug it into the network via a Powerline adapter.

    The 0.6 board would only connect to the Web Control if I plugged the Ethernet cable straight into the PC though, I never managed to get it to connect via the Poweline adapter.

    I really don't know enough about IP addresses to begin to fathom this out.

    I guess my nest step is to play around with the addressing on a setup that works and then try to apply that to the firmware I'm after using.

    If you have any ideas on the hotend fan though I would appreciate it.

    Thanks in advance


  • administrators

    The fan control is active low on the Duet 06, active high on the Duet 085. Later firmware versions manage the difference automatically, but older versions needed parameter I1 added to the M106 command on the Duet 085.



  • @jonnybrylcreem It's far easier to manage IP addressing through the DHCP server of your router. If you can log into your router you can probably find a way to reserve an IP address for each device on the network. That way the Duet can ask DHCP for an address and it will get the same one every time without worrying about address collisions happening when two devices are trying to use the same IP.



  • Thanks for the info @dc42, that resolved the issue with the fan.

    @Phaedrux , I've tried using DHCP and I just can't get it to work for some reason. My printer never appears on the list of devices on the router. If I give it a static IP address that resembles everything else that is connected to the router then I can't get it to work either.

    The only way it wants to work is if I give it an IP address that was set up years ago, when I first commissioned my Ormerod, on a different router. Using this old IP address (which I don't think should even work) the printer never appears as a connected device on the router (I can identify everything that appears connected) but it is clearly connected as I can operate the printer remotely via my iPad and upstairs PC. So I'm totally baffled.

    I would leave it at that but I'm trying to get both the 0.6 and 0.8.5 board to work and the only way I can currently do that is if I effectively clone the setup, which means I would only be able to use one machine at a time.

    I hope this makes (no !?) sense because it doesn't to me.

    Thanks for all your help though.



  • @jonnybrylcreem You have a typo in your 540 command,

    M540 PBE:EF:DE:AD:FE:ED should be
    M540 PDE:EF:DE:AD:FE:ED instead. DHCP should work once this has been corrected.



  • @ayudtee thanks very much I will give it a go.



  • Ok, so I did manage to get the board to connect to the network using DHCP using old firmware. I had forgotten to add a comment to disable the M554 gateway line.

    I should say at this point that I am pretty much blind in one eye and don't see too well with the other one, so I tend to miss little things like that. Sorry

    Having re-flashed the board with RepRapFirmware-1.21 however I am pretty much back to square one in that the board will not connect to the network via DHCP, @ayudtee I'm afraid that didn't solve the issue.

    I tried cutting and pasting the network commands from the other SD image as well but that didn't solve the issue.

    The hotend fan has started running flat out for a split second and then runs at the normal rate for a minute or so before revving up again. The fan led turns off briefly before the fan revs as well, as if the board is resetting.

    Any ideas?

    Apologies for all these questions, I was hoping this was going to be a quick job!



  • @jonnybrylcreem I have a Duet 0.8.5 running 1.21 on my Ormerod 2 printer and the 540 command that I use for DHCP is:
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address

    Hopefully this other format for the 540 command like I am using will also work for you.



  • @ayudtee that was the format that I cut and pasted in, it made no difference. I wondered if it was because my router already had that MAC address in memory from my other printer so I tried changing the last "ED" to "00". Still didn't work.

    I'm bound to have done something stupid, I just can't figure out what it is though.

    Cheers for the help



  • @jonnybrylcreem Try power-cycling your router, as DHCP was working for the Duet's mac address before you upgraded its firmware.



  • Could you repost the networking portion of your config.g as it currently sits?

    I was about to suggest modifying the mac address to make it unique, but I see that you've just tried that without success.

    Here is what I would expect to work. If you copy and paste this into your config make sure that the gateway address matches your router. 192.168.1.1 is default commonly, but not always.

    M540 PCB:E1:AB:70:29:79   ; Randomly generated MAC address
    M550 PTESTPRINTERNAME   ; New unique name for the printer, all caps
    M551 Preprap .  ; Default password
    M552 S1 P0.0.0.0 .  ; Enable networking and use DHCP
    M553 P255.255.255.0   ; Set default Netmask
    M554 P192.168.1.1  ; Gateway IP address. Should match the IP of your router
    

    If this were me troubleshooting, and that still doesn't work, I would attempt a factory reset on the router (after backing up and documenting the current configuration, and only connecting the Duet to the router and nothing else and seeing if the Duet shows up as a device.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.