Thermostatic heater fan and Simplify3D



  • I use a thermostatic Fan 1 for my heater, and nothing to cool part.

    M106 P0 S1.0 I0 F500 H1 T45

    The problem is S3D understand this fan as a part cooling fan.

    As a result, it inserts M106 S0 at the beginning, because I specify no cooling.
    This produces clogging, because excessive heating, and is risky also for wiring, 3D printed carriage, etc....

    Only workaround is to specify 100% cooling, which is also risky for the part if I use later another fan for cooling.

    Any idea to overcome this and avoid having extruder permanently cooled ? (noisy...).

    Many thanks


  • administrators

    According to your M106 command, you are using Fan 0 for the heatsink, not Fan 1. Preferably, use Fan 1 or Fan 2 instead. If you can't do that, add parameter F1 to each of your M563 commands, then the M106 S0 command sent by S3D will be redirected to fan 1 provided that you have a tool selected at the time.



  • Many thanks, works perfectly. Still learning gcode, but progressing....



  • Or you can go into the Firmware configuration in S3D and enter P1 into Fan Speed Control:
    0_1525278035187_12b69e31-590b-4b8c-a05c-c5ff62fe2e24-image.png


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.