I can't get the Bltouch working



  • Something is still not right the machine status Z-Probe is reading 1000



  • The probe status doesn't change visibly in the interface. It only flashes as it triggers and then goes back. You'll have to do a manual test to see if it stops the bed from moving during a G30. Raise the print head away from the bed and issue a G30 and the probe should deploy. Touch the pin with your hand to trigger it and the movement should stop. If it doesn't, turn the power off.



  • When I do the G30 I get this error. I am new to the Duet Wifi Board it is pretty hard to setup for the first time.

    Error: G30: Insufficient axes homed for bed probing

    Thank you for your help



  • You'll need to home x and y first.

    Then you can move the head into the position you want to probe.

    I recommend reading through these guides.

    https://duet3d.dozuki.com/c/Getting_Started

    The Duet is a bit different than other boards and firmware, but it's also a lot more powerful and flexible.



  • Done - Move the nozzle until it is at a good Z=0 height (for example a height that will touch but not pin a piece of paper against the bed).
    Done - Set this height as Z=0 with G92 Z0
    Done -Move the print head up perhaps a centimeter

    When I do this I get this error - Run a single probe without updating the printer's coordinates: G30 S-1

    G30 S-1

    Error: Z probe already triggered at start of probing move

    Thank you so much for the help you are great help.


  • administrators

    @saltypetz said in I can't get the Bltouch working:

    When I do this I get this error - Run a single probe without updating the printer's coordinates: G30 S-1

    G30 S-1

    Error: Z probe already triggered at start of probing move

    Does the probe deploy when you run that command?



  • No It does comes on. Now everything is good but the BLTouch
    But if I do this it come down and the blue light comes on.
    M280 P3 S10 I1
    If I lightly touch the BLTouch it goes up red led on and then comes down and the blue led comes on.

    When I put this in all the pin does is goes in and out without stopping and blue led is on.
    M280 P3 S120 I1

    G30 S-1

    Error: Z probe already triggered at start of probing move


  • administrators

    Which firmware version are you using? Have you set up your deployprobe.g and retractprobe.g files as described on the wiki page?



  • Here is the firmware I am running.

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 1.21RC3 (2018-02-28 build 4)
    WiFi Server Version: 1.21RC4(08b3)
    Web Interface Version: 1.21-RC4

    Editing 0:/sys/deployprobe.g
    ; Probe deployment routine for BLTouchon on Tevo Black Widow
    M280 P3 S10 I1

    Editing 0:/sys/retractprobe.g
    ; Probe retraction routine for BLTouchon on Tevo Black Widow
    M280 P3 S10 I1

    Also on duet Wifi Page where it say Z- Probe it says 1000. The BLTouch is wired with the Duet Wifi diagram.

    I know I am so close It is driving me crazy. I have been working on this for 2 weeks.

    Thank you,



  • @saltypetz your deploy and retract commands are the same.


  • administrators

    As @Phaedrux says, also please use the 1.21 release firmware not the release candidate.



  • I did everything you said rolled the firmware back to 1.20
    and then all this.
    Commissioning & Testing
    To test the setup with the nozzle maybe a 100mm up from the bed you can check if the trigger signal is reaching the Duet by attempting to extend the pin by using the following command:

    M280 P3 S10 I1

    Then put the Sensor in to test mode by inputting the following command:

    M280 P3 S120 I1

    If all is well the web interface should report a value of ” 0” in the Z probe column when the pin is extended. You can then lightly touch the extended probe pin to check that the pin retracts, the value in the Z probe Column should change to “1000”

    If all is good It is at this point that you can deploy the probe using the M280 P3 S10 I1 command and slowly lower the nozzle to the bed and find out your own Z trigger height, when the probe touches the bed and the pin retracts you can take a reading of the Z height and use that to input into the G31 command in the config.g file

    When the pin hit the bed it flashes red and the z says 3.60 but where is says Z-Probe is says 1000.
    is everything done know and ready to print.

    Thank you everyone for the help this board is real hard. Thank you



  • Now if i tell it all home it homes x and y and centers in bed then the BLTouch goes up and down continuously without stopping.blue and red led on.



  • It sounds like you have the servo command to do a self test in your deploy macro instead of the command to deploy.



  • I hate to sound really dumb but now you lost me. I did all home x and y homed no problem and the Z runs into the bed.
    Can you give me a little more information than that I am lost and I am only 2 weeks in trying to get it to work.
    I am a newbie with the Duet Wifi but I love it already. I cant wait to get it going.



  • Your Z homing routine should use G30 to do a probe. It sounds like its currently setup to work as if there were an endstop to trigger.

    Can you post your homing files?

    On my CoreXY my homeall.g looks like this

    ; homeall.g
    ; called to home all axes
    ;
    
    ; BLTouch prep so we don't catch the probe pin on the edge of the bed
    ;
    M280 P3 S160 I1 		; Alarm Release and Push-Pin UP just in case it's in alarm and deployed
    M402				; Retract probe just in case it's down
    
    ; Home XY for Z homing
    ;
    G91                     	; relative positioning
    G1 Z5 F200 S2        		; Lower bed 5mm to ensure it is below the switch trigger height
    M913 X50 Y50	 		; set X Y motors to 50% of their normal current for homing
    G1 S1 X-375 Y305 F4000   	; course home X or Y
    G1 S1 X-375 F4000              	; course home X
    G1 S1 Y305 F4000              	; course home Y
    G1 X2 Y-2 F1000             	; move away from the endstops
    G1 S1 X-10 F200           	; fine home X
    G1 S1 Y10 F200               	; fine home Y
    M913 X100 Y100	 		; set X Y motors to 100% of their normal current
    
    ; Z homing section follows
    ;
    G90				; absolute positioning
    G1 X190 Y90 F4000		; Move x and Y axis over to bed center so probe is on top of bed
    
    ; Set lower speeds for homing
    M566 Z5			; Set maximum instantaneous speed changes (mm/min) (Jerk)
    M203 Z350			; Set maximum speeds (mm/min)
    M201 Z100	 		; Set maximum accelerations (mm/s^2)
    
    ; Probe the bed
    ;
    M558 A1 F350			; Set single probing at faster feed rate
    G30 				; Do a single probe to home our Z axis
    M558 A10 F100			; Set tripple probing at slower feed rate
    G30				; Probe again to get a more accurate position
    
    ; Set normal speeds again
    M566 Z60			; Set maximum instantaneous speed changes (mm/min) (Jerk)
    M203 Z600			; Set maximum speeds (mm/min)
    M201 Z600			; Set maximum accelerations (mm/s^2)
    
    ; Move X and Y back Home
    ;
    G1 X0 Y270
    


  • ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri May 04 2018 09:52:38 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    M98 Pdeployprobe.g ; deploy mechanical Z probe
    G1 S1 X-585 Y-255 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-585 Y-255 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X-43.565 Y26 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed
    G1 Z5 F100 S2 ; uncomment this line to lift the nozzle after homing

    M98 Pretractprobe.g ; retract mechanical Z probe



  • If you are using fimrware version 1.21 you can remove the M98 commands to manually deploy and retract the probe, the g30 command will do it automatically.



  • I did that and xand y sitll home and the Z-Probe flashs red probe going in and out then crash into the borad.
    We are getting close.
    Right now Head Position reads X 100 Y 60 Z 15
    But then it say. The following axis is not homed z

    Thank so much for the help you have been great



  • What happens when you send the deploy and retract servo commands? Does it respond correctly?

    Can you post your current G31 and M558 commands from config.g?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.