BLT + DuetWiFi not triggering when Auto Delta Calibration



  • Hi All!
    I'm building a mini kossel with a DuetWifi and a BLT probe (current version). I've been reading several threads about setting up, wiring and configuration of the BLTouch on the DuetWifi controller. I fixed several of common setup and wiring issues, but I'm stuck on a problem when doing the Auto Delta Calibration. When running the calibration it homes the 3 towers, starts going down, but it never stops.

    I tried a few things suggested in other threads to check if the probe is working properly, like placing a led on the connector and check by touch if it triggers, and it lites on in evey try. I also got values sporadically on the Z Probe on the Machine Status section if I deploy it with M401 and trigger it by touch too.

    I'm currently using DuetWifiFirmware and DuetWifiServer on v1.21 and most of my config was done through RRF Configuration Tool.

    Thanks beforehand for any help I can get on the subject.

    ; config.g
    ; Drives
    M569 P0 S0                                ; Drive 0 goes forwards
    M569 P1 S0                                ; Drive 1 goes forwards
    M569 P2 S0                                ; Drive 2 goes forwards
    M569 P3 S1                                ; Drive 3 goes forwards
    M350 X256 Y256 Z256 E128 I0               ; Configure microstepping without interpolation
    M92 X1280 Y1280 Z1280 E1163               ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200              ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z9000 E1200              ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000              ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30           ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                   ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1                                ; Set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S0                          ; Set active low endstops
    
    ; Z-Probe BLTouch 
    M307 H7 A-1 C-1 D-1                       ; Disable the 7th Heater to free up PWM channel 5
    M558 P9 H3 F25 T500                       ; Set Z probe type to switch and the dive height + speeds
    G31 P5 X0 Y27 Z2.5                        ; Set Z probe trigger value, offset and trigger height
    M557 R85 S20                              ; Define mesh grid
    
    
    ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool 
    
    M561                ; clear any bed transform
    G29 S2              ; Clear bed height map
    G28                 ; home all towers
    M401                ; Deploy probe - deployprobe.g
    
    ; Probe the bed at 3 peripheral and 3 halfway points, and perform 3-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y64.45 H0 Z-99999
    G30 P1 X73.61 Y-42.5 H0 Z-99999
    G30 P2 X-73.61 Y-42.5 H0 Z-99999
    G30 P3 X0 Y25.95 H0 Z-99999
    G30 P4 X36.81 Y-21.25 H0 Z-99999
    G30 P5 X-36.81 Y-21.25 H0 Z-99999
    G30 P6 X0 Y0 H0 Z-99999 S3
    
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    M402                ; Retract Probe - retractprobe.g
    
    ; deployprobe.g
    M280 P7 S10 I1
    
    ; retractprobe.g
    M280 P7 S90 I1
    
    ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat May 05 2018 18:56:24 GMT-0300 (Argentina Standard Time)
    G91                        ; relative positioning
    G1 S1 X286 Y286 Z286 F1800 ; move all towers to the high end stopping at the endstops (first pass)
    G1 X-5 Y-5 Z-5 F1800 S2    ; go down a few mm
    G1 S1 X10 Y10 Z10 F360     ; move all towers up once more (second pass)
    G1 Z-5 F6000               ; move down a few mm so that the nozzle can be centred
    G90                        ; absolute positioning
    G1 X0 Y0 F6000             ; move X+Y to the centre
    

  • administrators

    @markost said in BLT + DuetWiFi not triggering when Auto Delta Calibration:

    When running the calibration it homes the 3 towers, starts going down, but it never stops.

    1. Follow https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe to check that the Z probe is working proiperly.

    2. When you are satisfied that the Z probe is working, make sure that the L parameter in the M665 command is set accurately, and the H and R parameters are set approximately correct. Also make sure your tower steps/mm are set correctly in the M92 command. Then, temporarily use a large H parameter in the M558 command to make the firmware start the probing move along way above where it expects the bed to be. This is to allow for your M665 H and R parameters not being right yet.



  • @dc42 Thanks!!!

    It seems that my caliper takes off measures above 140mm and I didn't noticed the first time (I mostly use it to take extremely small measuers). The homed height defined on M665 was higher by a couple of centimeters. Also the H parameter on M558 was too low, so all added up, the probe was expecting to trigger below the bed. I used a more analog method to take measures and it helped to solved the issue.

    My biggest mistake was to think that the probe will trigger at any height regardless of the other parameters, so I didn't think about checking the heights on those commands. Once you point me in the right direction I was able to quickly solve this issue.

    Thanks again!!!

    Marcos


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.