Keep Z axis microstepping but force to only move full steps



  • Hi,

    I have a Z axis with 100 full steps (1600 microsteps with 16x microstepping) per mm.
    It looks like even a full step resolution is ok, and the stepper motors have better holding torque & better accuracy on the full step boundaries, so that should be a way to go for my setup for better accuracy and quality.
    At the same time, I'd like to keep the stepper silent (which only works in 16x microstepping mode with interpolation).

    So are there ways to keep the stepper working in 16x microstepping + interpolation mode, but always make it moving in full step increments?



  • I can always make it moving in full step increments during the printing (by simply keeping the layer height multiple of 0.01mm), but I'm concerned about the homing which may end up in arbitrary unstable microstep value which I will always keep the same by using multiples of 0.01mm.

    The alternative solution to what I wanted above is maybe using full steps for homing and then somehow switching to 16x + I microstepping without losing the homed position. Is that possible?


  • administrators

    @zlowred said in Keep Z axis microstepping but force to only move full steps:

    The alternative solution to what I wanted above is maybe using full steps for homing and then somehow switching to 16x + I microstepping without losing the homed position. Is that possible?

    You should be able to do that by homing Z using full steps, then changing microstepping on the Z axis, then sending G92 Znnn where nnn is the exact Z height after Z homing.



  • That means G92 will set "homed" flag?
    That should be exactly what I want, thanks!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.