G30 command



  • So I am trying to install a bltouch. I have been going over the guide, I have it install correctly and it responds when I manually tell it to deploy and retract. What I don't understand is that when I issue the G30 command, all it does is come up as manual bed probing and wants me to physically move the nozzle up and down. It does not send the nozzle down towards the bed like it says its going to in the guide. Been messing with this all day and can't seem to figure out how to get rid of the manual probing (not even sure how I turned it on in the 1st place). Thank you.



  • Did you set the probe type in the M558 command? I happened to reproduce the behavior you are referring to by getting happy with the delete key and deleting the probe type during some work I was doing. Looks like P9 in your M558 is what is needed for the bltouch.

    Here is the relevant gcode info on selecting the correct probe type.

    http://reprap.org/wiki/G-code#M558:_Set_Z_probe_type

    Notes on setting up probe.

    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    and bltouch instructions just in case.

    https://betrue3d.dk/bltouch-on-duet-wifi-configuratio-and-usage/



  • ; Endstops
    M574 X1 Y1 S0 ; Set active high endstops
    M574 Z1 S2
    ; Z-Probe
    M558 P9 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to switch and the dive height + speeds
    G31 X48 Y24.5 Z0 P25 ; Set Z probe trigger value, offset and trigger height
    M557 X40:205 Y40:205 S20 ; Define mesh grid

    this is the part of my config.g file, it appears it is correct, maybe I am missing something.


  • administrators

    Please note, P9 in the M558 command is only supported in firmware 1.21 and later.


Log in to reply