Empty Layers causing incorrect layer count



  • My Duet Wifi reports about 40 empty layers at the start of each print (0 layer time, 0 extrusion) in the web-interface. After that the layer counting works as intended, but of course the empty layers throw off the layer count as well as print time estimate.

    My End-Gcode has a Z-move, but i have already added the ;E comment to it.

    The issue only appears since updating to version 1.21 of the firmware and web-interface. Layer counting worked fine on version 1.19.

    Thank you in advance for any replies 🙂



  • https://pastebin.com/VEKjWGjk

    ^ Example Gcode.
    note: the issue also comes up with the previous version of Slic3r


  • administrators

    I don't know the exact reason, but suspect these commands are confusing the print monitor:

    G1 Z0.200 F6000.000
    G1 Z0.250

    What is the reason for moving the head to Z=0.2mm, when the layer height is 0.25mm?



  • I was assuming that it is being generated because Z-hop is enabled. I was wondering about the unusual number of Z-commands at layer change too, it seems that the current implementation of Prusa Slic3r generates both a Z-hop and the actual layer change every time.
    I'm not sure if that's causing the issue though, because those bunched up Z-moves are present all througout the file, but the Web Control page shows empty layers only at the start of the print, after completing the first real layer. The problem also appeared after updating the Duet Firmware, while still using the same version of Slic3r as before.

    I'll try to run some code without the Z-hop next time and see if that fixes the issue. I'll also take a screenshot of the Web control page 🙂


  • administrators

    The Z hop should be OK, I use it on one of my printers. An example of the Z hop in that file is that it rises from X0.25 to Z0.45 a little later in the file. But Z hop doesn't explain the G1 Z0.200 at the start.



  • @dc42 I can confirm that the G1 Z... commands are caused by Z-Hop.
    I'm assuming this is a bug in Prusa's code that causes a hop both when going from Z=0 to the first layer height and then again when going to the actual print starting position.
    I will try to see later today if a print without Z-hop also causes the weird web-interface behavior.

    I have also taken pictures of the web interface showing the empty layers:
    0_1526480741502_Layer count issue.jpg

    Layers 2-50 are practically empty, after that everything works normally.

    Edit: Printing with Z-hop disabled still causes the empty layers, even though there is only one Z-command at every layer change now.


  • administrators

    Please can you provide a GCode file with Z hop disabled that exhibits the problem. It will be easier to debug.



  • https://pastebin.com/uUgfuXVR
    This Gcode was generated with Z-Hop off, but still caused the empty layers issue.


  • administrators

    @warriorme said in Empty Layers causing incorrect layer count:

    https://pastebin.com/uUgfuXVR
    This Gcode was generated with Z-Hop off, but still caused the empty layers issue.

    Thanks for the file. Unfortunately due to other commitments I am unlikely to look at it before Monday.



  • From a remark you made earlier, I assume that you are using a Prusa version of Slic3d, if so, be very careful \ suspect for the gcode that it gives, as the Prusa versions are almost hard-coded for his printers e.g. board configuration, mesh leveling etc. while giving great results on a Mk2\Mk3 but inconsistent results on other printers.

    I have also tried the Prusa version of Slic3r but have settled for the standard version of Slic3r and simplify3d.


  • administrators

    @warriorme said in Empty Layers causing incorrect layer count:

    https://pastebin.com/uUgfuXVR
    This Gcode was generated with Z-Hop off, but still caused the empty layers issue.

    Thanks. I've tried printing that file. My observations:

    • I removed the heating commands and instead enable cold extrusion. The current layer remained stuck at zero. On investigation, this turned out to be because the print monitor insists that a nozzle has reached operating temperature before it considers that a print has started.

    • If I set the temperature of tool 1 to 100C and then run it, the current layer increments with Z height exactly as I would expect.

    When you get the "empty layers" issue, does the current layer remain stuck at 0 while the issue persists? If so then it's probably something to do with the way the print monitor module monitors the heating.



  • I currently don't have access to my printer, i will check if that is the case tomorrow.

    Meanwhile, since this seems to not be a common issue i was thinking about the conditions that might be different in my case specifically to cause this behavior. The empty layers seem to always be listed after the first layer is completed, so could the issue be caused by:
    -Having the printing temperature reduced by a few degrees after completing the first layer while also
    -Having the standby temperature set to the first layer's printing temperature (I manually set it before printing so that the tool doesn't cool down while homing)

    I was thinking that might confuse the logic since for most users there would be no reason to have a standby temperature higher than the priting temperature...

    Again, i will test for this too when i have access to my printer tomorrow.


  • administrators

    Please test with firmware 2.0RC5 tomorrow - I think you may find the issue is fixed in that version.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.