No X/Y Homing on duet 1.02 with 1.19.2 now 1.21



  • Hello,

    I setup now another duet WiFi 1.02 with fw 1.19.2 on it. Everything is fine, fans, leds, endstops, bltouch, jog movement but if I call home x ( homex.g „G28 X“) I got the error push () stack overflow, error: homing failed. I upgraded fw to 1.21 successfully but same error happens
    And because of the update no jogging is possible I know! What else can I do? A downgrade fails until now because of that it wants a combinedfirmware file.
    I think there must be a problem in my config perhaps, which I send in the first answer. I lvl be thankful for any help



  • ;Communication and general
    M111 S0 ; Debug off
    M550 ThreadCore125L ; Machine name and Netbios name (can be anything you like)
    M551 xxyyzz11aa23 ; Machine password (used for FTP)

    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address

    ;*** Networking
    M552 S1 ; Turn network on
    M586 P0 S1 ; Enable Http

    ;*** Ethernet networking: Adjust the IP address and gateway in the following 2 lines to suit your network
    M552 P0.0.0.0 ; (0 = DHCP)
    M554 P192.168.1.255 ; Gateway
    M553 P255.255.255.0 ; Netmask

    M555 P2 ; Set output to look like Marlin
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Endstops
    M574 X1 Y1 S1 ; set endstop configuration (all endstops at high end, active high)
    M574 Z0 S2 ; set endstop configuration (all endstops at high end, active high)
    M307 H7 A-1 C-1 D-1
    M558 P5 X0 Y0 Z1 H5 F200 T5000
    G31 P25 X-15 Y70 Z2.5
    M557 X14:514 Y41:441 S20

    ; Axis and motor configuration
    M584 X0 Y1:4 Z2 E3
    M569 P0 S0 ; Drive 0 goes backwards X
    M569 P1 S0 ; Drive 1 goes backwards Y
    M569 P2 S1 ; Drive 2 goes forwards Z
    M569 P3 S1 ; Drive 3 goes forwards E0
    M569 P4 S0 ; Drive 4 goes backwards Y2

    M350 X16 Y16 Z16 E16 I0 ; Set 16x microstepping with interpolation
    M92 X128 Y128 Z1066.6 E415 ; Set axis steps/mm
    M566 X600 Y500 Z120 E200 ; Maximum instant speed changes mm/minute
    M203 X20000 Y20000 Z180 E3600 ; Maximum speeds (mm/min)
    M201 X1600 Y1300 Z100 E2000 ; Accelerations (mm/s^2)
    M906 X2000 Y1680 Z1920 E700 I100 ; Set motor currents (mA) and increase idle current to 60%
    M84 S300

    ; Thermistors
    M143 S260;
    M305 P0 T100000 B3950 C0 R4700 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4267 C0 R4700 ; Put your own H and/or L values here to set first nozzle thermistor ADC correction
    M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds

    ; Fans
    M106 P0 H-1 ; Disable Fan 0 thermostatic mode
    M106 P1 H-1 ; Disable Fan 1 thermostatic mode

    ; Tool definitions
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures

    ;*** If you are using axis compensation, put the figures in the following command
    ;M556 S78 X0 Y0 Z0 ; Axis compensation here
    ;M208 S1 Z-0.2 ; set minimum Z

    M564 H0

    T0 ; select first hot end
    M117 Ready to Print !



  • Now downgraded back to 1.19 and testing again with same result! Everything is fine incl jog moving but now homing, always push() stack overflow


  • administrators

    1. By default, firmware 1.21 does not allow normal axis movements (including jogging) before that axis is homed. See the upgrade notes for 1.21 for details and how to revert to the old behaviour if you need to.

    2. Stack overflow messages generally mean that you have created a recursive macro. For example, you may have a G31 command in homeall.g and a G28 command in bed.g.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.