First layer issues.



  • Hi,

    I can't get my first layer to stick and it seems like the nozzle is too high. Using baby steps doesn't really help me. I am going well beyond -4mm. Can anyone help? I am suspecting that the bed compensation doesnt get read or something.

    I am trying to set up my z probe. I am converting the Prusa MK2 to the duet. I am running into an issue with my z height. First I will start with how I have it hooked up. It requires 5v so I hooked it up to the expansion slot 5v pin, the ground to the E0 limit switch ground and the signal to the E0 limit switch signal.

    The probe is set up to trigger around 4mm, and it does. Mesh bed leveling gives me a pretty skewed plane, but nothing that can't be handled. I have a spring steel base with a PEI sheet bonded to it. The top of the surface is about 1mm away from the metal plate.

    When I call G29, it does 9 points around the bed just like the MK2 does. Then I home it.

    This is my Z-Probe set up
    M574 Z2 S2 ; Set endstops controlled by probe
    M558 P4 H5 F240 T7200 I0 A3 ; Set Z probe type
    G31 P1000 X0 Y0 Z0.00 ; Set Z probe trigger value, offset and trigger height
    M557 X12:238 Y4:206 S100 ; Define mesh grid

    This is my start g-code script:
    M83 ; extruder relative mode
    M104 S215 ; set extruder temp
    M140 S60 ; set bed temp
    M190 S60 ; wait for bed temp
    M109 S215 ; wait for extruder temp
    M561 ;forget previous meshes
    G28 ;home
    G29 ; home and mesh bed leveling
    G29 S1
    G1 Y-3.0 X4 F3000.0 ; go outside print area
    G92 E0.0
    G1 Z0.2 ;Go down to surface
    G1 X60.0 E9.5 F1000.0 ; intro line
    G1 X100.0 E12.5 F1000.0 ; intro line
    G92 E0.0


  • administrators

    @pineapplesystems said in First layer issues.:

    In this line:

    G31 P1000 X0 Y0 Z0.00 ; Set Z probe trigger value, offset and trigger height

    You have the probe X and Y offsets set to zero, and the trigger height also set to zero. I suggest you set the X and Y offsets to the correct values, then calibrate the trigger height as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.



  • Hi!

    Thanks for the reply. I calibrated this and set the z height as well. I set it to X23 Y9 Z0. The 0 i got from that z probe calibration with the g92 z0 command. Still no luck though. Going to try to print something with a large bed surface area now. See what's happening.



  • @dc42 No luck. I followed the whole process. I put on something with a big surface area, I am doing the baby stepping yet nothing is changing. This is my updated z probe definition:

    M558 P4 H5 F240 T7200 I0 ; Set Z probe type
    G31 P1000 X23 Y9 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X28:225 Y10:208 S90 ; Define mesh grid

    Any other ideas? I explored my extruder steps per mm value as well and got that calibrated too.



  • @dc42 This is my entire config file:

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z400 E161.3 ; Set steps per mm
    M566 X600 Y600 Z12 E150 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z720 E7200 ; Set maximum speeds (mm/min)
    M201 X9000 Y9000 Z500 E10000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y-2.2 Z0 S1 ; Set axis minima
    M208 X250 Y210 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    ;M574 Z2 S2 ; Set endstops controlled by probe
    M558 P4 H5 F240 T7200 I0 ; Set Z probe type to ultrasonic and the dive height + speeds
    ;M558 P1 Z1 F500 T7200 H5 I0
    G31 P1000 X23 Y9 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X28:225 Y10:208 S90 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • I feel like you're missing a step in the calibration. I would think your Z offset should be something other than zero. If you are doing all of the steps, then zero should be your nozzle touching the bed.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.