Duet Ethernet wont connect to Network



  • Hi everyone
    Im new here so please bear with me.

    So I've been building a costum 3Dprinter from scratch and am now trying to install the duetEthernet.
    I've had the Ethernet hooked up in my old printer and it was working perfectly. Now i've transfered it all over to the new one and suddenly it wont connect to the Network anymore. It still connects via USB and i can send commands via Pronterface, but everything i tried so far didnt fix the problem.

    Here's a list of stuff i tried:
    -Firmware update
    -diffrent cable and ports
    -reconfigured the whole configfile
    -diffrent sd card

    Im pretty sure the board isnt damaged. I can still disable and enable the Network.

    when i send the command m552 this is what it gives me back:
    SENDING:M552
    Network is enabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0

    Im kinda lost now and dont know what i should do. So maybe someone here can help?

    Thanks in advance.
    Xenjamo


  • administrators

    please post your config.g




  • administrators

    Is your router/dhcp server actually seeing the Duet to give it an IP address? You could try assigning an address that is not is use, within the subnet that your local network uses. and seeing if you can connect to the Duet



  • No the Board is not showing. I tried assigning an andress but nothing happens. Not even the LED on the connector light up, On the switch or the Duet.
    Something else when i try to update the board it asks for Duet2CombinedFirmware.bin and not DuetEthernetFirmaware.bin. Maybe this is what's causing the Problem?

    When i assigne an adress the response is:
    SENDING:M552
    Network is enabled, configured IP address: 192.168.1.105, actual IP address: 192.168.1.105

    but still no connection.


  • administrators

    If the LED on the ethernet switch does not light up that indicates a physical hardware probelm. can you connect it to the ethernet port of your laptop to see what happens.

    The firmware is not an issue, David changed the firmweare to use the same binary for both wifi and ethernet. see:
    https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md

    "The binary filename for the Duet WiFi and Duet Ethernet is now called Duet2CombinedFirmware.bin. However, your existing firmware version may expect it to be called DuetWiFiFirmware.bin or DuetEthernetFirmware.bin. For your convenience, this release includes copies of Duet2CombinedFirmware.bin with those names."



  • Alright. This is weird. So I removed the Board from the Printer to hook it up directly to the computer. And then it worked. The LEDs lit up and i was able to access the webtool.
    But then when i shoved it back in the printer reconnected everything but then it didnt work.
    i found that when i unplug the IR-Probe the board works normally. This is super wierd. Does the board go through a selfcheck each startup und something is wrong with my IR-probe?


  • administrators

    It does sound like there may be an issue with the IR board (possibly shorting to ground?) check that the IR board cables are ok and not shorted, also that the board is not shorted against the heatsink



  • Alright i think i can handle it from here. Sometimes complex problems have simple solutions.

    Thank you for your time.
    Xenjamo


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.