G28 Z Error: G0/G1: insufficient axes homed



  • Hi, Sorry it's my first day with the Duet, I think everything is going forward, but I'm stuck with Z homing, I bet it's an easy fix but I'm not used to it yet 😞
    I don't have a Z probe and I don't want to do auto-leveling. For now I just want to home Z to the MIN endstop (0). X and Y are fine. Z moves up (toward the endstop) about 5mm then stops. My endstop is working (it's wired by normally-closed).
    What should I correct please? Here's my config.g

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu May 17 2018 18:22:58 GMT+0200 (CEST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    M587 S"Xiaomi5772" P"Kahel2000" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z800 E418.5:418.5 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X24000 Y24000 Z400 E6000:6000 ; Set maximum speeds (mm/min)
    M201 X5000 Y5000 Z250 E250:250 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X400 Y350 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:385 Y15:335 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X-18 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


    Here's my homeall.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu May 17 2018 18:22:58 GMT+0200 (CEST)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-405 Y-355 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-405 ; home X axis
    G1 S1 Y-355 ; home Y axis
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-405 F360 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y-355 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed
    ;G1 Z5 F100 S2 ; uncomment this line to lift the nozzle after homing


    Here's my homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu May 17 2018 18:22:58 GMT+0200 (CEST)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 S2 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • administrators

    Please go to the FAQ page in the wiki (it's under Troubleshooting) and read item #1.



  • Thank you! I got it homing now. I'm loving this board, the firmware and the support!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.