FAN1 Stopped working



  • Fan one has stopped working it reads as 13.5V but will not power a fan. The always on fans work and I have tried connecting the cooling fan to them and that works. So it appears I am having a problem with the board.

    The cooling circuit had been working fine as the fan had been cutting in but now appears to be dead.

    Any idea where to look next?


  • administrators

    Most likely the FAN1 mosfet has failed due to short circuit or overload. What did you have connected to it?



  • Maplin DC 12V 0.10A 40mm Fan


  • administrators

    That seems odd then. Are you sure that you don't have a bad crimp connection on the fan connector? Is there any sign of damage to TR9, the mosfet next to the FAN1 connector? Hads the fan ever been connected the wrong way round?



  • No, it was working fine, turned it off restarted it next day and no fan. The fan is noisy but it does work.



  • As I have two other not always on fan connections can I just change the firmware to use another one?


  • administrators

    @designedby36 said in FAN1 Stopped working:

    As I have two other not always on fan connections can I just change the firmware to use another one?

    Yes, you can configure the firmware to use FAN2 instead of FAN1. Just change P1 in the appropriate M106 command to P2, or change F1 in the M563 command to F2.



  • so

    ; Tools
    M563 P0 D0 H1 ; Define tool 0

    becomes

    ; Tools
    M563 P1 D0 H1 ; Define tool 0

    and how do I change the fans?

    ; Fans
    M106 P0 S0.1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on


  • administrators

    You are not using fan mapping in your tool definitions, so no changes needed there. You already have fan 2 configured the same way as fan 1. So it should just work.



  • New board fixed the issue but I have swapped from a V1.02 to the latest board and now my homing won't work, I get the error. Does it on all 3 axis.

    G28 X

    Error: G0/G1: insufficient axes homed

    So what has changed

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops
    M558 P0 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y0 Z0.1 ; Set Z probe trigger value, offset and trigger height
    M557 X15:485 Y15:485 S20 ; Define mesh grid

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 09 2017 11:28:54 GMT+0000 (GMT Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 ; lift Z relative to current position
    G1 S1 X-505 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000 ; go back a few mm
    G1 S1 X-505 F360 ; move slowly to X axis endstop once more (second pass)
    G1 Z-5 F6000 ; lower Z again
    G90 ; absolute positioning



  • Sorry found it the board needs S2 on the Z axis commands, what does S2 do?


  • administrators

    @designedby36 said in FAN1 Stopped working:

    Sorry found it the board needs S2 on the Z axis commands, what does S2 do?

    Amongst other things it overrides the "no movement before axis has been homed" default behaviour in the 1.21 firmware. The other way of overriding it is to include M564 H0 in config.g.


Log in to reply