Confusing extruding problem



  • Hello,

    I recently purchased a duet WiFi and upgraded to a new end-effector/hotend combo. Since I've done this I can't get my extruder to push filament through, it keeps clicking and/or grinding depending on the motor current I set. It goes through fine at first and then gets harder until it's impossible to push trough. I'ts also not possible pushing it through by hand.

    At first I thought it might've been a clogged hotend so i cleaned it out but accidentally screwed up the heat-break (the one with a tube inside). So I got an all metal one and tried that but the same problem still occurred. I thought maybe i assembled it wrong or maybe the heat-break didn't fit all too well, it was from China after all. So i bought a new e3d v6 from China and still the same problem occurred. I figured it might be lack of cooling so i switched back to my old hotend that came with my printer and it still had the same problem. I also changed the PTFE tube so that's not the issue either.

    Right now I feel like it might be an incorrect temperature reading because I can't think of anything else, it can't really be a broken thermistor either as I used three different ones. In my config file I added this line for the supposedly proper thermistor setup; M305 P1 T100000 B3950 C0 R4700.

    I'm at a loss for ideas here i feel like I've tried everything I hope you guys can help me.

    Greetings, Piet.


  • administrators

    If the filament goes through OK at first but then gets harder to push, it's likely a problem with the hot end, the hot end cooling or retraction:

    • Personally I would never buy an all-metal hot end from China, because having a good surface finish inside is critical to clog-free operation.

    • All-metal hot ends are very sensitive to excessive retraction

    • All-metal hot ends are also sensitive to insufficient fan cooling of the heatsink.



  • @dc42 The strange part is that the hot-end that is currently on the printer came with it and hasn't had any changes and it always printed fine before.

    edit: My printer is an anycubic kossel and it comes with a e3d v5 clone.


  • administrators

    Check that the heatsink fan always runs (at least when the hot end temperature is more than about 45C), and that you are not using more retraction than before.

    The quoted B value of 3950 for that thermistor is almost certainly measured at fairly low temperatures, so it is quite likely that the hot end temperature is not accurate. You may want to try increasing it.

    HTH David



  • @dc42 The fan is always on and i haven't used retraction because it hasn't run yet since i got the new board. To what value do you suggest increasing it too?


  • administrators

    @piet, don't use retraction or pressure advance until you have solved the hot end clogging problem. Perhaps you should try a higher extrusion temperature.



  • @dc42 So yesterday i decided to buy a infrared thermometer to check the actual temperature, it turns out when i set the temperature to 210 in the duet web interface the thermometer shows a value between 120-180 (i don't know why it varies so much but its hard to pinpoint an exact temperature and location). How do i resolve this?

    Greetings Piet.


  • administrators

    IR thermometers are OK for reading the bed temperature, but cannot get an accurate reading of hot end temperature. For that you should feed a thermocouple into the hot end in place of the filament.


Log in to reply