Auto calibration problem with 256 microstepping



  • As the title says, I have a problem if I set the microstepping to 256 without interpolation in the config file. After running the autocalibration routine, the web interface stops responding and I don't get an output under the g-code console. If I refresh the page, the web UI comes back up. I've copied the config below.

    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)

    M665 R133.301 L269.00 B140 H373.837 ; set delta radius, diagonal rod length, printable radius and homed height
    M350 X256 Y256 Z256 I0
    M350 E16 I0
    M92 X2560 Y2560 Z2560 ; Set axis steps/mm
    M906 X2000 Y2000 Z2000 E1000 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X800 Y800 Z600 E600 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
    M566 X1480 Y1480 Z1200 E600 ; Maximum instant speed changes mm/minute

    ; Thermistors
    M305 P1 X200
    M305 P0 T100000 B3950 R4700 H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction

    M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds
    M307 H1 A398 C163.4 D12.9 B0
    M307 H0 A380.5 C788.7 D26.7 S0.50 B0

    ; Fans
    M106 P0 H-1 ; disable thermostatic mode for fan 1
    M106 P1 T45 H1
    ; Tool definitions
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    M92 E467:467 ; Set extruder steps per mm

    M558 P1 X0 Y0 Z0 H3 ; Z probe is an IR probe and is not used for homing any axes
    G31 X0 Y0 Z1.34 P500 ; Set the zprobe height and threshold (put your own values here)

    M556 S78 X0 Y0 Z0 ; Axis compensation here

    M208 S1 Z-.2 ; set minimum Z
    T0 ; select first hot end



  • To add onto this, it works fine setting microstepping to 128 and steps/mm to 1280


  • administrators

    I have added this to my list of things to test. However, at 2560 steps/mm your movement speed will be severely limited. I recommend you use lower microstepping until I have implemented dynamically varying microstepping.



  • I understand, just like testing out options. I was able to still print at 35mm/sec, but did back it off.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.