Noise from heater triggering z-probe



  • I am wondering if anyone else has ever had an issue where the heater turning on causes the "detect" LED to blink randomly. I first noticed it when it was printing because it kept failing to calibrate properly, but then magically worked (heater was probably stable). I am going to check the electrical wiring to make sure I have adequate ground but wasn't sure if there is something else I should look for.

    Again, I turn the heater on, heater LED turns on (orange) and the Green LED blinked wildly. Turn the heater off LED works as expected.



  • Actually I think it is either the Duet3D (unlikely) or my power supply is on its way out. When I turned it off by the power supply and turned it back on the problem went away. So I am going to pretend like this never happened and go on my merry way.


  • administrators

    It's not impossible that the magnetic fields from the bed heater could cause false triggering, especially if it is a high-current bed heater. Some other types of Z probe (e.g. bltouch) are also affected by bed heater current. That's why the M558 command has an optional B1 parameter, to turn off the bed heater during probing.

    However, as the problem seems to have cleared itself, perhaps this isn't the explanation.



  • @dc42 Actually I have determined how to work around the issue. Once the print starts it slowly decays and begins to error. Interestingly enough resetting the power supply is the only fix I can find right now. To be clear the only way the LED blinks out of control is when the hotend heater heats up, not the bed.



  • Is the B1 addition to the M558 command supposed to turn the extruder heater off as well?


  • administrators

    @mgrimes1907 said in Noise from heater triggering z-probe:

    Is the B1 addition to the M558 command supposed to turn the extruder heater off as well?

    Yes, it turns all heaters off.



  • Now that I know about that too, I can drop the M144 hack from my bed.g, Thanks!

    Any chance of having a similar parameter for the fans / fans too? Its really not important just a suggestion..

    BTW if I set for example M558 A8 then it still fails sometimes with an error "probe triggered before initial move" or something very similar, and does not retry that point. [smart effector, set to quite sensitive]



  • Yes - Bed Heater causes annoying flickering of effector LED's ONLY when at temperature and also causes false triggering of probe.



  • @dc42 - I don't think it has anything to do with magnetic effect - the noise does not happen during heating only when at target temperature. It is something to do with switching to maintain an even bed temperature - it affects the effector led's and the probe. Turning off the bed heater during probing is a not a fix - it is desirable to probe with heaters on for maximum accuracy, especially during mesh grid compensation. The flickering white LED's on the effector are very annoying during printing and really shouldn't happen - gives me a headache if I watch a print for more than a few minutes.


  • administrators

    @pilotltd said in Noise from heater triggering z-probe:

    @dc42 - I don't think it has anything to do with magnetic effect - the noise does not happen during heating only when at target temperature. It is something to do with switching to maintain an even bed temperature - it affects the effector led's and the probe. Turning off the bed heater during probing is a not a fix - it is desirable to probe with heaters on for maximum accuracy, especially during mesh grid compensation. The flickering white LED's on the effector are very annoying during printing and really shouldn't happen - gives me a headache if I watch a print for more than a few minutes.

    If the white LEDs flicker as the bed heater turns on and off, then the voltage at the VIN terminals of the Duet is dropping significantly when the bed heater is on. This may be caused by:

    • Bad connection in the VIN wiring, e.g. VIN terminal block screws not tight;
    • Wires between the PSU and VIN too thin;
    • Poor PSU voltage regulation, perhaps because you are running it at the limit of its power output capacity.

    So check the connections, then use a multimeter to measure the voltage at the PSU output and at the VIN terminals to see how much the PSU output drops when the bed heater turns on, and whether the VIN voltage drops significantly more.

    If you are satisfied that everything is in order, you can increase the bed heater PWM frequency (F parameter in the M307 command) to e.g. F100 so that the flicker is too fast to see.

    The B parameter in the M558 commands only turns off the heaters briefly during each probing move, so that the temperature drop is minimal.



  • Thanks - the F100 fixes the visible flickering, the probe still shows false triggering when the bed temp is stable so it hides, but doesn't fix the actual source of noise. My voltage with everything on is 12.8V but it drops to 12.4 with everything on and printing. All wire sizes are more than adequate for the loads and there are no loose or bad connections. It seems to me that maybe the corrections sent the bed heater are far more frequent than actually needed? On my bed it takes 14 seconds to drop 1 degree. I don't know how often it checks though when at target temperature. It is only when at target temperature when the problem appears and only on the bed heater. I have a much better 12/24V 60A regulated power supply at work which I'll substitute and see what happens, but I suspect it's a hardware problem with insufficient filtering somewhere on the power supply, Duet Wifi board or the smart effector. I'll get it on the oscilloscope during the week and see if I can find where it's from.



  • B1 definitely solved the noise problem for good. The issue now is that I found at higher temps (like 255C) the time it takes for it to probe 16 points the nozzle cooled about 15C despite it trying to keep the nozzle warm between points. Is there a gcode command that tells it to wait until nozzles are warm? I didn't see one on my first pass through reprap gcode.


  • administrators

    @bpislife, the command to wait for temperatures to stabilise is M116.

    To maintain temperature during mesh probing, here are some suggestions:

    • faster probing speed (F in M558)
    • lower travel speed (T in M558)
    • lower dive height if the bed is flat enough

  • administrators

    PS what type of Z probe is it?



  • I've recently had an issue where trying to simplify wiring by pairing up grounds on micro switches caused false triggers. If you are sharing grounds on the probe try running it straight back to the duet.

    Edit: Sharing grounds didn't necessarily cause the spikes that resulted in the false trips but wiring both sides of the limit micro switches back to the board has been more tolerant to whatever was causing the spikes.



  • @dc42 This is the smart effector. Turning off the bed and using the B1 command takes care of it. I will try to reduce the probe height.



  • @doctrucker Its definitely a noise problem I am facing when the heaters are one and trying to probe. Likely my PS is dipping slightly as the heaters are running or the bed heater is running. B1 disables the heaters while it is probing, the problem is naturally the hotend cools down too fast. and starts the print a little on the cold side. manually pausing the print, letting it come back up to temp and hitting resume resolves this, was just looking for something a little more automated.


  • administrators

    @bpislife said in Noise from heater triggering z-probe:

    @doctrucker Its definitely a noise problem I am facing when the heaters are one and trying to probe. Likely my PS is dipping slightly as the heaters are running or the bed heater is running. B1 disables the heaters while it is probing, the problem is naturally the hotend cools down too fast. and starts the print a little on the cold side. manually pausing the print, letting it come back up to temp and hitting resume resolves this, was just looking for something a little more automated.

    If you are using either G32 or G29 in your slicer start Gcode, just add M116 after that command.



  • @dc42 perfect! That’s what I couldn’t find. I was looking for pause not weight which is why I couldn’t find it.

    Thanks for the help!!!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.