Ultimaker Z axis config problem.



  • Hi. I tried configure my Ultimaker. Z axis on home action move to the endstop and set position ftom config. But ufter any G command for X,Y or Z axis bed moving to zero position and on the next G command to max position and so on the circle. During print simulation or real print beg any time go up and down.
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jun 02 2018 22:48:38 GMT+0300 (RTZ 2 (зима))

    ;M111 S0 ; Debug off
    M575 P1 B57600 S1 ; Set auxiliary serial port baud rate and require checksum (for PanelDue)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M667 S0 ; Select Cartesian
    G21 ;Set in mm

    ; Drives
    M569 P0 S1 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z400 E377 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z2400 E2700 ; Set maximum speeds (mm/min)
    M201 X2500 Y2500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I20 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z294 S1 ; Set axis minima
    M208 X213 Y199 Z0 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops
    M574 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 X0 Y0 Z0 H5 F120 T6000 I1 ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y0 Z0.4 ; Set Z probe trigger value, offset and trigger height
    M557 X15:198 Y15:185 S20 ; Define mesh grid

    ; Heaters
    M305 P0 X201 ; Configure thermocouple for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M301 H1 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P1 X200 ; Configure thermocouple for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0.1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool
    ;M501 ; Run config-override.g

    ; Network
    M550 PDuetUltimaker ; Set machine name
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    M552 S1 ; Enable network



  • @afigentus said in Ultimaker Z axis config problem.:

    M574

    Can you post the Homez.g file?



  • ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jun 02 2018 22:48:38 GMT+0300 (RTZ 2 (зима))
    G91 ; relative positioning
    G1 S1 Z295 F6000 ; move Z up until the switch triggers
    G1 Z-10 F6000 S2 ; lift Z relative to current position
    G1 S1 Z295 F500 ; move Z up until the switch triggers
    G92 Z0.2 ; set Z position to trigger height

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 S2 ; lift Z relative to current position
    G90 ; absolute positioning

    HomeZ action is correct, but then ...


  • administrators

    @afigentus said in Ultimaker Z axis config problem.:

    G91 ; relative positioning
    G1 S1 Z295 F6000 ; move Z up until the switch triggers
    G1 Z-10 F6000 S2 ; lift Z relative to current position
    G1 S1 Z295 F500 ; move Z up until the switch triggers
    G92 Z0.2 ; set Z position to trigger height

    1. You are moving Z up to a Z max endstop switch, but then telling the firmware that the nozzle-to-bed distance is 0.2mm at that point. That isn't right.

    2. In your M208 commands you have said that the Z minimum is 294mm and the Z maximum is zero. That isn't right either, the minimum can't be greater than the maximum.

    The Z coordinate refers in all cases to the distance between the nozzle and the bed. So if it is the bed that moves up and down, the Z max position is when the bed is at its lowest point, and the Z min position is when the bed is at its highest point.

    So I suggest you fix your M208 commands, and re-evaluate whether you are homing to a maximum or minimum Z endstop.

    HTH David



  • many thanks. figured out with your help. works as it should.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.