New beta Duet WiFi firmware bundle

  • administrators

    I have put new BETA firmware at Try it if you are brave enough! Here are the changes since the last official release:

    DuetWiFiFirmware version 1.15 beta 3:

    • Speeded up the step pulse generation, to allow faster movement when higher microstepping is used
    • Fixed an issue that caused lookahead queue underrun when printing a series of very short gcode segments at high speed
    • Report additional status information from the WiFi module

    DuetWiFiServer version 1.01:

    • Speeded up page loading. Thanks to roboduet for his insight into why it was slower than it needed to be.
    • Return the firmware version and additional WiFi module status information to the main processor
    • If the WiFi module can't connect to the access point and therefore creates its own access point, inform the main processor

    DuetWebControl version 1.11b-dc42:

    • If a status request times out, do one retry before reporting an Ajax error
    • Use a fixed-width font in the config.g file editor (thanks mhackney)
    • [EDIT] Fixed two incorrect filenames that prevented some functionality from working (thanks mhackney)

    Please install the new main firmware (DuetWiFiFirmware.bin) before the new wifi module firmware (DuetWiFiServer.bin). This is because te old main firmware will not recognise the new status message sent by the new wifi firmware.

  • administrators

    PS - I just made a correction to DuetWebControl.bin. The new file has a timestamp of 17:44. If you downloaded the earlier version, please download it again.

  • Due to the ajax disconnects I am experiencing I copied the files to the microSD card and then booted from it (web and main firmware first, then removed card and added server firmware)

    It was still reporting to web interface as 1.14 so I uploaded the firmware again from the web interface, upload completed ok but I had a timeout during the end of the installation step (PanelDue reported upgrade had completed though)

    Checked SD card no firmware file so uploaded again via computer to card and now when I try to power up PanelDue is stuck at connecting, and I can't connect via web interface.

  • administrators

    Hi Brian, please follow the steps listed at under Backup procedure #2.

  • Just finished 2-hour printing with this firmware using 70mm/s default printing speed. Model sliced using S3D slicer, 200 steps/rev steppers and the following settings:

    M350 X64 Y64 Z64 E16 I1
    M92 X400 Y400 Z400

    Everything is OK, model is smooth and clean, diagnostic message is also looking good: [c]MaxReps: 5, StepErrors: 0. Underruns: 0[/c]

    The only thing I missing is how to check WiFi server firmware version (this one: DuetWiFiServer version 1.01)

  • administrators

    When the wifi starts up, the wifi firmware version is reported to USB and PanelDue. Currently there isn't a way to get it from the web interface.

  • Hi David

    I followed your instruction but no luck, had to go back to procedure #3.

    But I'm still stuck due to the following error occurring in Windows 10 (Virtualization on OS X) when clicking connect in SAM-BA, I either get this or the window just disappears when I click connect.. (have tried running with Windows 7 and 98 compatibility and same error).

    I did find an old reference with a similar message from someone using SAM-BA 2.12, but couldn't find a solution or any reports of the same with 2.16.


    Hi Brian, please follow the steps listed at under Backup procedure #2.

  • Brian, I suspect you did not select the board in SAM-BA as described on the wiki page. The board should be atsam91sam4e8-ek. I got that exact dialog the first time I tried it and had not set the board.

  • Brian. you mentioned ajax disconnects. Can you describe what's happening please. I was rock stable for the first couple of days I installed the Duet WiFI then yesterday I attempted to upload a modified DWC.bin and I can't stay connected for more than a few seconds before I get disconnected. Is this what's happening in your case?

  • @mrhackney

    This is what I have the settings at before clicking connect:

    I've been having a massive amount of ajax disconnects ever since I connected to a secondary wireless network, while I had only ever connected to one network it was rock solid and I never had any disconnects (1.13 firmware), since changing network or updating firmware I get disconnects all the time (on 1.14 firmware).

    I was hoping that upgrading to this beta version may help, but it's left me with an unusable printer at the moment 😞 thats what I get for being brave I guess.. πŸ™‚

  • administrators

    Brian & Michael,

    I'm sorry to hear that you have both been experiencing problems since installing new firmware. If you want to revert to the original firmware that was installed on the pre-production boards when they were shipped, you can find it here:

    If that gets it working well again over an extended period of time, please try upgrading either the main firmware (DuetWiFiFirmware.bin, installed using M997 S0) or DuetWebControl.bin (installed using M993 S2) and see if it is still reliable.

    If you encounter any instances of web interface disconnects and then you find that you can't reconnect, then first try closing the browser tab and connecting in a new one, in case DuetWebControl has got into a state it can't recover from. If that doesn't work, then if possible open your router's status page showing connected wireless devices, and see if the Duet WiFi is still connected. Currently, if your router kicks the Duet off the network, it won't attempt to reconnect unless you stop and re-start the WiFi module. I will fix this in the next DuetWiFiServer release.

  • I just tried again and for some reason SAM-BA worked this time.. was able to reflash with the beta version and PanelDue and the web interface are connecting now! πŸ™‚

  • Hi,
    This new version works well for me (window 7 64b).
    There is a little bug in the duet web control, it's not possible to replace a file even if you delete it before trying to upload it.
    I've to rename it. Deconnecting from the session doesn't solve this for me.

  • I'm still getting web interface ajax timeouts with this version.

  • Can somebody try to dump network traffic using Wireshark to and from DuetWiFi board with this ajax timeouts issues?

  • All, when you get the ajax timeouts can you please report if you are able to reconnect or if you have to reset/reboot the Duet board please. In my case, once I get the timeout I can not reconnect even if I try from a completely different browser or computer.

    I am doing a fresh re-install of the original pre-production binaries as I type and I will capture the network traffic with Wireshark too.

  • All, I have reverted back to the pre-production code and captured a complete trace with Wireshark. The link to the trace and details are on my thread here:

  • I get more problem of ajax time out, usualy i can reconnect but few minutes ago i had to unplug the printer due to an emergency !
    How to use wireshark ? I installed it but i do not know what to enter…

    I 'm getting this time out mainly when i upload a file to the printer. I've to redo the upload with a new file name otherwise it doesn't work. Also i notice it crash when the upload didn't start at full speed.

  • Learning how to use Wireshark is not terribly difficult. Basically, after launching you need to select the interface to watch - in this case, WiFi. Then you need to apply a filter for IP address to capture traffic from, otherwise you get a lot of extraneous info. You can just capture everything and we can filter out stuff from the log too but I prefer to set a filter. My filter looks like:

    ip.addr ==

    Your IP will be different (your Duet WiFi IP - get it from Pronterface when you issue a M552 S1)

    By the way, I have discovered that once I get the comm failure I can turn off and then turn on WIFI in Printerface and it will reconnect:

    M552 S0
    M552 S1

    I get the time out even if I connect and just sit there and watch with no activity. Try that and see what happens, I bet you'll timeout too.

  • I am able to reconnect, however I get dropped again after not too long (particularly when in the middle of a print).

  • I installed and get wireshark listening my duet, to be sure i reinstalled the last bundle firmware but no timeout connection since 10min

  • No problems with the update for me, all installed fine.

    The print motion looks different to me, I can't quite put my finger on exactly what it is, but almost like accelerations have slowed down very slightly or maybe smoothed, but it may be just be me remembering what it was like in the last release.

    Anyone see or 'feel' and difference?

    Producing very good print results, so I'm happy.



  • I cannot confirm that the motion is slower in this new version but i notice a hudge difference when the model is like a low polygonal model with straight path than a curvy model. My extruder was clicking at 200mm/s on the polygonal and i've to slow down to 150 to get it work correctly, the hotend temperature was insanely high for PLA and on the curvy model with near the same loop length and without short curve, no problem.

    Did you feel this on the same model ?

  • I've upgraded without any obvious issues and been connected on and off for 6 hours so far via the web page though no actual prints yet πŸ™‚

    Upgrade was done via the web page for all the modules without any issues.

  • David, I've been keeping statistics on disconnects the last few of days and been monitoring my network for the last day. Firstly, the original network issues that were antagonizing my original issue are gone so that is no longer a factor.

    My other 5 deltas are running Duet with a TP-Link wifi bridge and Duet Wifi are all on the same network. The other 5 are running 1.09z-ch firmware and 1.11 HTML and JS.

    In 72 hrs I've had 1 of the 5 disconnect one time but the other 4 have stayed connected (both printing and sitting idle over night) for 3 days.

    The Duet WiFi has disconnected 8 times in the same time period. The good news is, a simple click of Connect and it reconnects quickly.

Log in to reply