Print Problem, Continuous Rubbing Of The Head.



  • good afternoon David, I do not know what else to play and what to do, I have several configurations in my delta and the result is the same, with smart effector my result is the same as with effector design a friend in our group, the calibration goes well gives me an error of 0.011 and the mesh gives me an error of -0.001 and aparaentemente this all correct, at the time of printing the head for more than you go up the distance of the nozzle with the bed is still skimming and ends up making layers unlinear and deforming the pieces, it is as if the z-axis as a whole was not capable of climbing all the correct steps, I raise the baby steping and it continues to graze the same in the next layer.
    my printer is a delta custom, with handy wands and effector custom rods, 1.8 motors with 16t pulleys, could you help me with this problem that affects several people?
    thank you very much for everything, greetings Santiago.


  • administrators

    Please post your config.g and bed.g files.



  • ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Mar 01 2018 10:31:26 GMT+0100
    M561 ; clear any bed transform
    G28 ; home all towers
    ; Probe the bed at 12 peripheral and 3 halfway points, and perform 7-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y149.9 H0 Z-99999
    G30 P1 X74.95 Y129.82 H0 Z-99999
    G30 P2 X129.82 Y74.95 H0 Z-99999
    G30 P3 X149.9 Y0 H0 Z-99999
    G30 P4 X129.82 Y-74.95 H0 Z-99999
    G30 P5 X74.95 Y-129.82 H0 Z-99999
    G30 P6 X0 Y-149.9 H0 Z-99999
    G30 P7 X-74.95 Y-129.82 H0 Z-99999
    G30 P8 X-129.82 Y-74.95 H0 Z-99999
    G30 P9 X-149.9 Y0 H0 Z-99999
    G30 P10 X-129.82 Y74.95 H0 Z-99999
    G30 P11 X-74.95 Y129.82 H0 Z-99999
    G30 P12 X0 Y74.9 H0 Z-99999
    G30 P13 X64.87 Y-37.45 H0 Z-99999
    G30 P14 X-64.87 Y-37.45 H0 Z-99999
    G30 P15 X0 Y0 H0 Z-99999 S7
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Mar 01 2018 10:31:26 GMT+0100
    ;
    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M665 R155 L360.26 B150 H440 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them
    ;
    ; Network
    M550 PChikyMaker XL ; Set machine name
    M552 S1 ; Enable network
    M587 S"NO ROBES AMIGO" P"Z0002CFA91EA6" I192.168.1.134 J192.168.1.1 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    ;
    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X256 Y256 Z256 E256 I0 ; Configure microstepping without interpolation
    M92 X1600 Y1600 Z1600 E6640 ; Set steps per mm
    M566 X600 Y600 Z600 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X2500 Y2500 Z2500 E2000 ; Set accelerations (mm/s^2)
    M906 X1100 Y1100 Z1100 E1000 I20 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    ;
    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z
    ;
    ; Endstops
    M574 X2 Y2 Z2 S0 ; Set active low endstops
    M558 P4 H40 I1 F400 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    M557 R130 S15 ; Define mesh grid
    ;
    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S285 ; Set temperature limit for heater 1 to 285C
    ;
    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ;
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    ;
    ; Automatic saving after power loss is not enabled
    ;
    ; Custom setting
    ;
    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    M375 ; Load the height map from file and activate bed compensation

    I attached the 2 files, I hope you can help me find my fault, this configuration is for the normal effector that I have now, before the frustration made me remove the smart effector. thank you very much.

    [Post edited by dc42 to improve readability of config.g and bed.g file contents]


  • administrators

    If you don't have the Smart Effector installed, what Z probe are you using?



  • @dc42 said in Print Problem, Continuous Rubbing Of The Head.:

    If you don't have the Smart Effector installed, what Z probe are you using?

    A probe that is placed in the nozzle and activated by pressing the nozzle conrtra the bed.
    0_1528560782578_f58cc91d-1232-420a-b0eb-b3881ee20ed3-imagen.png


  • administrators

    Have you calibrated its trigger height?



  • @dc42 said in Print Problem, Continuous Rubbing Of The Head.:

    Have you calibrated its trigger height?

    I did not calibrate


  • administrators


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.