Remap the nozzle Heater from Duet to duex5



  • Hello,

    i would like to remap the nozzle heater 1 and 2 to the duex5 heater system.
    wich parameter should i change ?

    this is my config file for the heater and tool section.. my extruders are connected at the duex5 at E3 Mot and E4 Mot and the thermistors are also connected to the Duex5. but i heat them up at the standart E0/E1 Heater and i Would like to change this to E3 Heat and E4 Heat on the duex5 here is the config part from heater and tools:

    • Heaters
      M307 H0 A42.4, C192.7, D4.9, S1, B0 ; Use PID on bed heater (may require further tuning)
      M305 P0 T100000 B3950 R4700 ; Set thermistor + ADC parameters for heater 0
      M143 H0 S120 ; Set temperature limit for heater 0 to 120C
      M307 H1 A290.4, C142.9, D3.7, S1 ; Use PID on Heater 1
      M305 P1 T100000 B4725 C7.060000e-8 R4700 X4 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 4
      M143 H1 S280 ; Set temperature limit for heater 1 to 280C
      M307 H2 A339.5, C146.2, D4.0, S1 ; Use PID on Heater 2
      M305 P2 T100000 B4138 C0 R4700 X5 ; Set thermistor + ADC parameters for heater 2 and remap it to channel 5
      M143 H2 S280 ; Set temperature limit for heater 2 to 280C
      P25.3, I1.215, D61.5

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:2 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S160 ; Set initial tool 0 active and standby temperatures to 160C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X0 Y-18 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S160 ; Set initial tool 1 active and standby temperatures to 160C*


  • administrators

    E3 Heat and E4 Heat are heater numbers 4 and 5 respectively. So:

    • change P1 to P4 and P2 to P5 in the M305 commands;
    • change H1 to H4 and H2 to H5 in the M307, M143 and M563 commands.


  • got it thanks!
    the problem was with the remapping X4/X5 after i deleted this and set them as P4 and P5 it worked 🙂


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.