External Stepper Driver problems with breakout board



  • Greetings,
    I'm attempting to build a large format printer for my community college, but I've been unsuccessful getting my Y axis stepper to do anything.

    Specs:
    Duet Ethernet 2.0
    Stepper Breakout board v1.1
    st-m5045 stepper driver (needs 5v signal)
    nema 23 4.2A stepper

    The other steppers are nema 17s running off the duet. Everything but the stepper driven by the external driver works perfectly.

    What we've tried so far:
    Mapping the drives with m584
    Adding T3 pulse with m569
    Different connections on the breakout board
    Triple checking all wiring

    The stepper locks at startup, but unlocks and the coils are not energized when we attempt to home. The problem seems to be that we're only getting 3.3v from the breakout board instead of the required 5v. Checking ena while it's attempting to home only gives us a reading of 3.13v. Same with pulse and direction. We were expecting all the signals to be 5v when using the breakout board, but we're ready to be corrected.

    We've been beating our heads against this problem for a couple days. Any advice you guys can give would be greatly appreciated.

    Cheers, Mike


  • administrators

    @etcmike said in External Stepper Driver problems with breakout board:

    The stepper locks at startup, but unlocks and the coils are not energized when we attempt to home.

    That means you have the wrong Enable polarity. In the M569 commands for those drives, if you have R1 then change it to R0 or leave the R parameter out altogether.



  • ******EDIT: I tried adding R1 and it works now. I thought I had tried that parameter before but apparently had not. Thanks for the help!

    There was no R in the M569. I tried adding R0 but it didn't do anything. I also tried R1 and R-1 as well as adding M18 as I saw in a similar thread, but to no avail.

    Here's the drives section of the setup gcode. The problem stepper is the Y axis assigned to drive 5. I really appreciate the help.

    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 T3 ; Drive 5 goes forwards
    M584 X0 Y5 Z2 E3:4:1 ; Apply custom drive mapping

    M350 X16 Y16 Z16 I0 ; Configure microstepping without interpolation
    M350 E16:16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1886 E420:420:420 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250:250:250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800:800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.