duet wifi/rrf2.0 stuck with M25



  • Hi,

    weird issue,

    started a print from web ui.
    tried to pause it with M25 from serial
    tried to pause from web ui
    manage to get M122 :
    http is doing "M25" in state(s) 0
    telnet is idle in state(s) 0
    file is doing "M190 S80" in state(s) 0
    serial is doing "M25" in state(s) 0

    now it's stuck, can't do anything from either serial or webui, can't reconnect to webui.

    going to power cycle it...



  • this was happening with duet only powered from usb port.
    Is it possible to prevent a print or to fail some gcode commands if there's no "main" power ?
    Looking at the pause macro, It won't success without power, that's M112 I should have tried.


  • administrators

    It looks like the print file is trying to heat the bed (which will fail if there is no VIN power, unless you are using an AC mains bed heater and SSR), and the web channel is waiting to pause the print. I guess it's waiting for the heating to complete. However, it should still be possible to press Emergency Stop in the web interface.

    I'm not sure that all users would agree on preventing prints or commands from running when there is no VIN power. If a machine either has no heaters (e.g. CNC) or only heaters controlled via SSRs, and only external drivers, then VIN power may not be needed to execute a print file.



  • Ok make sense, I guess it could as well be configurable.
    Anyway, since I've not been able to resolve my duet wifi issues, I have implemented this on my duet proxy. (network/http server done with a python daemon that communicates via usb serial)


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.