Anycubic linear plus duet Wi-Fi conversion



  • Hi all. Complete noob here ready to redo my delta with the duet 2 wifi board. As well doing some other non vital upgrades. I suspect I might be back here more than once asking for advice. I’ve read the other builds in this forum, and I hope I won’t have as much trouble as them 😉

    I’m on my first hurdle. My inherited power supply is a 12v 25a box with two reds and 2 black wires. Previous board had two set of connections for them. On the board it says benieth 5A and 11A. The cables seems the same, so when I had it hooked up, each connection set got a red and a black each, and that worked fine.

    How do I make the power supply work with the duet board? Merge the blacks and the reds separately? I’m extending the wires as well, so I got a 16awg cable to use. Is 16 enough?

    Just to add, it also has a heat bed. Maybe I should use the two sets of wires for power and heat Bed?

    Thanks for any help you guys can provide.



  • Yes, run all + outputs of the supply to the + on the Duet, and all - PS to - Duet.

    16awg is OK-ish depending on your total amp draw, which is almost all bed heater and hot end heater. It could potentially be a little thin, if you were drawing right at the max for that power supply. Wouldn't hurt to go a little thicker. If you stick with 16, DO, absolutely do, take care to use well crimped "bootlace" connectors on everything. No solder, no bare wires, just crimped bootlaces. They handle the most current.

    LOTS of ways to run the bed "semi separate", perhaps with an external mosfet or SSR, so we'd have to pick one to discuss it with any clarity.



  • @danal

    Hi Danal. Feel like I know you from all the other Anypubic threads 🐶

    I’ve opened the power adapter up and going to use insulated crimp ring connector to the power supply, and the ferrules that came with the kit.

    Decided to do it properly, and ordered 12awg wire for the job as well.

    Thanks!



  • @hagenland said in Anycubic linear plus duet Wi-Fi conversion:

    I’ve opened the power adapter up and going to use insulated crimp ring connector to the power supply, and the ferrules that came with the kit.

    Decided to do it properly, and ordered 12awg wire for the job as well.

    Sounds great!



  • Hi all. I got it all connected now, with good wiring, and have a few more issues;

    My 7” touch screen is stuck on “connecting’, not showing any live data, using the send connection option.

    When I try to autocalibrate, the 2-pin switch? that came along the printer, goes bang into the build plate. It doesn’t seem to react to the sensor being pushed. I tried pushing it manually On the way down, and that doesn’t stop it. However, when idling, I see it going from 0 to 1000 when I press the button, so it’s getting the signal.

    The extractor temperature sensor doesn’t work. It worked before the upgrade. I tried to connect the hotbed temp sensor (that works) in the same spot, and still no luck, so it’s a setting or something.

    My config:

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 16 2018 21:17:52 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R162 L268 B85 H400 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 Delta ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E96 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 H20 F100 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 R85 S20 ; Define mesh grid

    ; Heaters
    ;M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    ;M301 H0 S1.00 P10 I0.023 D305.4 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    ; #define DEFAULT_bedKp 10.00
    ; #define DEFAULT_bedKi .023
    ; #define DEFAULT_bedKd 305.4
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    ;M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P1 X200 ; Set heater 1 to PT100
    M143 H1 S300 ; Set temperature limit for heater 1 to 280C
    ;M307 H1 A333.1 C233.4 D3.2 S0.5 B0
    M307 H1 A363.3 C222.7 D2.9 S0.5 B0
    M307 H0 A127.6 C744.3 D0.7 B0

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool
    M501

    ———————-——

    Bed config:

    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G31 X0 Y0 ; don't want any probe offset for this
    G28 ; home the printer

    ; The first time the mechanical probe is used after deployment, it gives slightly different results.
    ; So do an extra dummy probe here. The value stored gets overwritten later. You can remove this if you use an IR probe.
    G30 P0 X0 Y0 Z-99999

    ; Probe the bed and do 6- or 7-factor auto calibration
    G30 P0 X-73.6 Y-42.5 Z-99999 ; X tower
    G30 P1 X0 Y-85 Z-99999 ; between X and Y towers
    G30 P2 X73.6 Y-42.5 Z-99999 ; Y tower
    G30 P3 X73.6 Y20 Z-99999 ; between Y and Z towers
    G30 P4 X0 Y67 Z-99999 ; Z tower
    G30 P5 X-73.6 Y20 Z-99999 ; between Z and X towers
    G30 P6 X-36.8 Y-21.25 Z-99999 ; half way to X tower
    G30 P7 X36.8 Y-21.25 Z-99999 ; half way to Y tower
    G30 P8 X0 Y42.5 Z-99999 ; half way to Z tower
    G30 P9 X0 Y0 Z-99999 S6 ; centre, and auto-calibrate 6

    G1 X0 Y0 Z150 F1500 ; get the head out of the way of the bed


  • administrators

    @hagenland said in Anycubic linear plus duet Wi-Fi conversion:

    My 7” touch screen is stuck on “connecting’, not showing any live data, using the send connection option.

    The usual cause is a problem with the 4-way cable (or the ribbon cable, if you are using that instead) between the PanelDue and the Duet. The ribbon cable alone doesn't work on older Duet PCB revisions.

    The other possible cause is mismatched baud rates. Both the Duet and PanelDue default to 57600.

    When I try to autocalibrate, the 2-pin switch? that came along the printer, goes bang into the build plate. It doesn’t seem to react to the sensor being pushed. I tried pushing it manually On the way down, and that doesn’t stop it. However, when idling, I see it going from 0 to 1000 when I press the button, so it’s getting the signal.

    Test your Z probe as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.

    The extractor temperature sensor doesn’t work. It worked before the upgrade. I tried to connect the hotbed temp sensor (that works) in the same spot, and still no luck, so it’s a setting or something.

    Please provide more detail. How have you connected the "extractor temperature sensor"?



  • Hi. Thanks for the response.

    Touch screen issue is now resolved. It was the baud thing.

    I went through the z-probe testing and calibration, and came through it to the end. I added the number I got with G30 S-1, to the G31 in config. Which was -0.554. But it still crashes into the bed. Does it matter that the magnetic sensor that came with the kit is positioned about 20mm under the nozzle? Is this something I should take in account?

    Heat sensor. I’ve connected the extruded heat sensor to the E0 as well tried E1. Like this:
    alt text
    https://www.icloud.com/sharedalbum/#B0ZJtdOXmJqWHBU

    Also, the error message on the panel consol is; ‘Error: Temperature reading fault on heater 1: sensor short to other wiring’

    Also, in regards of the z-probing, I tried to my bed config line by line, to see where the problem happens and it’s at line 8:
    G30 P0 X0 Y0 Z-99999



  • Update. I tried connecting the extruder temp sensor to the hotbed pins, and that works. So I know the sensor is fine.



  • Update 2: I rebooted with the temp sensors disconnected, and I still get the fault on heater 1. Could this mean that the board is faulty?



  • Updated 3: temp issue on extractor is resolved. It was set up as the wrong type in config. Probably what the error message was reacting to.



  • Zprobe problem - I’ve switched to extruder end stop Mode 6. Exactly the same problem though. Sensor goes from 0 to 1000, but auto calibration grinds the plate.



  • Z-probe update; I changed the Z parameter to 100 (from -0.554) G31 in the config, just to see what happened, now it seems to work. I expected it to float way above the hotbed, but it didn’t. I do get a couple of “Error: Z probe already triggered at start of probing move”.

    I’ve read the references of the G31 code, but don’t really understand it, and don’t know what ramifications having the Z set to 100 will have.



  • Ok. Think I got it figured out. The problem was in the top of the config under the delta config. The height was set to 400. I replaced this number after having done a homing, so I could see what my real height is. Funnily enough it says in the config it’s to replaced and was set artificially high.

    This is now my new line;

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R162 L268 B85 H295.75 ; Set delta radius, diagonal rod length, printable radius and homed height


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.