Fan always on with M106 P1 H1 T50



  • Sorry if this has been up before. Cant search all day

    So did something break?

    Edit: This is FW 2.0 btw

    I have tried many configurations and fan0 and fan1 but it is just alway on. Did something break on the board?

    ; Fans
    M106 P1 T50 H1

    ; Tools
    M563 P1 D0 H1 ; Define tool 0



  • So I tried FA2 and it worked for a While but now it is also always on - reading M106 P2 answers:

    Fan2 frequency: 500Hz, speed: 100%, min: 10%, blip: 0.10, inverted: no, temperature: 50.0:50.0C, heaters: 2, current speed: 0%:



  • So all the PWM Fans is now always on - even if I do M106 PX S0

    Reading is ok but fan is blowing... what could have happened?

    Still runs wit this
    Fan1 frequency: 500Hz, speed: 0%, min: 10%, blip: 0.10, inverted: no, temperature: 50.0:50.0C, heaters: 0, current speed: 0%:



  • Curious about an answer about this since I have exactly the same problem, all pwm fan keep blowing.
    I suspect a blown mosfet on F1 here, but F0 and F2 just keep the fans at 100%

    Config:

    ; Fans
    M106 P0 S1 I0 F500 H0 T45
    M106 P1 S1 I0 F500 H-1
    M106 P2 S1 I0 F500 H-1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0

    Temp on Tool 0 (Heater 1) reads 23°, so F0 shouldn't be running
    Same M106 answer as pro3d



  • @undergod YOu have F0 responding to BedHeater thermistor - And F0 is not usually used as thermocontrolled fan. F1 (P1) is the one commonly used as heatsink fant with thermo controll but then you need

    M106 P1 S1 I0 F500 H1



  • @pro3d oh my... changed the P0 fan to H1 heater (stupid mistake) and fan0 now is off.
    fan2 is still blowing 100%, but I'll look if I also made an error elsewhere.
    Thanks!!!



  • @undergod You cant have H-1 it must be H1 or H2 or H0. H-1 is then not thermocontrolled



  • @undergod This is something like standard:

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T50 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H0 T50 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on



  • @pro3d Yeah, so this works as expected now:
    M106 P0 S1 I0 F500 H1 T45
    Fan0 stays off untill 45° is reached on the hotend and goes off after it goes under 45° again.

    Now to tackle the second one 🙂
    commented all the F1 and F2 lines, and now the fan won't run, so must be a config error somewhere! (sorry for hijacking your thread like that btw, I thought I had quite a similar problem 🙂



  • @undergod What?

    The fan should be off as long as temp is below 45... That is the whole point with T45. And you should use FAN1 for this not FAN0.

    Understand?
    Standard config is:
    Fan0
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    Fan1
    M106 P1 S1 I0 F500 H1 T50 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on



  • For my second fan I just set plainly this:
    M106 P2 S0
    it is working as wanted now: off as standard, and can be controlled when needed.

    Clarification: the fan0 is also working great, maybe I explained it wrong:

    . fan0 is off
    . heater1 gets to at least 45°
    . fan0 starts running
    . heater1 gets under 45°
    . fan0 stops running

    That is this line: M106 P0 S1 I0 F500 H1 T45

    So except for my blown mosfet on Fan1, everything here is solved, again sorry pro3d but much much thanks for your help!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.