Anycubic Linear Duet 3d extruder still running too fast



  • Hi,

    So I've set cura to absolute (as using 2.4.0) in the slicer settings and also in config.g It does seem to have slowed it down a bit but it's still running fast causing skipping as the extruder can't keep up.

    Look at this video I took

    https://youtu.be/QuaWX6vPlsQ

    any idea why this is happening, it seems to be running to quick. could it be hardware, or do you think software. Here's my slicer staat code and then my config.g

    G21 ;metric values
    G90 ;absolute positioning
    M107 ;start with the fan off
    G28 ;move to endstops
    M82
    G92 E0 ;zero the extruded length
    G1 F200 E3 ;extrude 3mm of feed stock
    G92 E0 ;zero the extruded length again
    G1 F{travel_speed}
    ;Put printing message on LCD screen
    M117 Printing...

    here's my config.g

    ; General preferences
    G90 ; Send absolute coordinates...
    M82 ; ...but absolute extruder moves

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R136 L288.15 B120 H217 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    M587 S"GoogleWifi" P"EMMETT24" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E663 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 R0.4 H5 F1200 T6000 ; Set Z probe type to effector and the dive height + speeds
    G31 P100 X0 Y0 Z-0.211 ; Set Z probe trigger value, offset and trigger height
    M557 R120 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M501
    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    Please help, I'm losing my patience 🙂



  • @sparkymark79 said in Anycubic Linear Duet 3d extruder still running too fast:

    663

    Where did you get your steps/mm value for the extruder from? If you got it from another firmware then was that firmware using the same microstepping?

    A Google search for anycubic linear configuration returns the following page:

    https://github.com/SpainLabs/Anycubic-kossel-3d-printer/blob/master/Configuration.h

    which has the following line:

    #define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 80, 96 }

    I'm not suggesting you just blindly copy this figure but there is a massive variation. That extruder looks to be ungeared which, again, is suggestive of a low steps/mm figure being correct. The documentation has a section on ungeared extruders here:

    https://duet3d.dozuki.com/Wiki/Choosing_an_extruder_drive#Section_Un_geared_extruders

    which suggests values of around 100.

    Hope this helps.

    adavidm



  • @sparkymark79 said in Anycubic Linear Duet 3d extruder still running too fast:

    M92 X80 Y80 Z80 E663 ; Set steps per mm

    ah ok, this is interesting

    so this lin here:

    M92 X80 Y80 Z80 E663 ; Set steps per mm

    am i right in thinking my extruder is set to 663 steps per mm?

    it should be more like 96?

    thanks for your help



  • That's right. Apologies, I had intended to copy and paste the whole line, not just the number!

    You should get somewhere in the right region with 96. I'd still recommend you fine-tune the extruder after doing that though. There are loads of tutorials on how to do that, including Thomas Sanladerer's here:

    https://toms3d.org/2014/04/06/3d-printing-guides-calibrating-your-extruder/

    On the Duet, you can send an M92 command while the printer is running. e.g.

    M92 E96

    and you can see the results straight away. Use a guide like Tom's to get the figure as accurate as possible, then modify your config.g with the new value.

    adavidm


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.